Last Comment Bug 750853 - mozilla/a11y/Role.h:817: error: comma at end of enumerator list
: mozilla/a11y/Role.h:817: error: comma at end of enumerator list
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 OpenBSD
: -- normal (vote)
: mozilla15
Assigned To: Hubert Figuiere [:hub]
:
:
Mentors:
Depends on: 716644
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 13:00 PDT by Landry Breuil (:gaston)
Modified: 2012-05-04 02:27 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix build (700 bytes, patch)
2012-05-01 13:05 PDT, Landry Breuil (:gaston)
hub: review+
Details | Diff | Splinter Review
Remove trailing comma at end of enumerator list, breaks build on OpenBSD. (782 bytes, patch)
2012-05-01 15:52 PDT, Hubert Figuiere [:hub]
hub: review+
Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2012-05-01 13:00:28 PDT
http://hg.mozilla.org/mozilla-central/diff/330f6adec1ec/accessible/src/base/Role.h broke the build on OpenBSD with the error message in summary.. fix in a few.
Comment 1 Hubert Figuiere [:hub] 2012-05-01 13:01:27 PDT
I'll fix it
Comment 2 Landry Breuil (:gaston) 2012-05-01 13:05:26 PDT
Created attachment 620036 [details] [diff] [review]
Fix build
Comment 3 Hubert Figuiere [:hub] 2012-05-01 14:01:44 PDT
let me know if you need somebody to land it.
Comment 4 Landry Breuil (:gaston) 2012-05-01 14:17:50 PDT
(In reply to Hub Figuiere [:hub] from comment #3)
> let me know if you need somebody to land it.

Well, yes since i can't land it myself :)
Comment 5 Hubert Figuiere [:hub] 2012-05-01 15:07:01 PDT
will land it once m-i is reopen.
Comment 6 Hubert Figuiere [:hub] 2012-05-01 15:51:28 PDT
Actually, I'll let the checkin team do it. Putting back the keyword.
Comment 7 Hubert Figuiere [:hub] 2012-05-01 15:52:03 PDT
Created attachment 620107 [details] [diff] [review]
Remove trailing comma at end of enumerator list, breaks build on OpenBSD.
Comment 8 Hubert Figuiere [:hub] 2012-05-01 15:53:10 PDT
Comment on attachment 620107 [details] [diff] [review]
Remove trailing comma at end of enumerator list, breaks build on OpenBSD.

Updated with proper commit message checkin. Thanks !
Comment 9 Landry Breuil (:gaston) 2012-05-01 23:24:27 PDT
It seems there's another breakage related to #716644..

../../dist/bin/libxul.so.1.0: undefined reference to `nsAccessibleWrap::AtkRoleFor(mozilla::a11y::roles::Role)'

But the code is there in nsAccessibleWrap.cpp and is not #ifdef'ed out...
Comment 10 Hubert Figuiere [:hub] 2012-05-01 23:39:54 PDT
For that last one, make sure you have
https://hg.mozilla.org/mozilla-central/rev/992588c2eab6
Comment 11 Landry Breuil (:gaston) 2012-05-01 23:49:45 PDT
Ah that might be https://hg.mozilla.org/mozilla-central/rev/992588c2eab6 from https://bugzilla.mozilla.org/show_bug.cgi?id=716644#c65 which i didnt have yet in my checkout.
Comment 12 Landry Breuil (:gaston) 2012-05-02 02:20:28 PDT
Confirmed, that was it.
Comment 14 Ed Morley [:emorley] 2012-05-04 02:27:25 PDT
https://hg.mozilla.org/mozilla-central/rev/e18b59be7262

Note You need to log in before you can comment on or make changes to this bug.