Closed Bug 750857 Opened 9 years ago Closed 7 years ago

Seamlessly switch from panning subdocuments to panning the main document

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(blocking-fennec1.0 -, fennec+)

RESOLVED DUPLICATE of bug 776030
Tracking Status
blocking-fennec1.0 --- -
fennec + ---

People

(Reporter: kats, Unassigned)

References

Details

This is a follow-up from bug 750722, but is a general issue that might fix other bugs such as 732364.

The basic problem is if you have a page with an iframe, and the user tries to pan the page by putting their finger down on the iframe, we will pan the iframe instead. Once the iframe is panned to the end and can be panned no more, we stop all panning activity; the user then has to lift their finger and put it back down and start panning again to pan the main page.

This bug is to determine whether it makes sense to change our behaviour to allow the user to seamlessy switch from panning the iframe to panning the main document once they reach the end of the iframe. If the answer is yes, we should determine if flings (i.e. high-velocity pans that let the page keep moving after the finger is up) should be propagated to main page as well.

CC'ing ibarlow to get the UX feedback for ^
Nom'ing since it sort-of blocks bug 750722 which is a release blocker.
Blocks: 750722
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → soft
not going to block on it, but this is something we want as soon as reasonable.
tracking-fennec: --- → 15+
blocking-fennec1.0: soft → -
tracking-fennec: 15+ → +
Kats this is probably a dupe of one of the subframe scrolling bugs you've been working on
Whiteboard: [mentor=kats]
Yeah APZC implements scroll handoff already so we'll get this for free once we switch. Fling handoff is different, but we have bug 965871 filed for that on the APZC side.
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: uiwanted
Resolution: --- → DUPLICATE
Whiteboard: [mentor=kats]
Duplicate of bug: apz-fennec
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.