Last Comment Bug 750959 - Re-enable incremental GC on Android
: Re-enable incremental GC on Android
Status: RESOLVED FIXED
[k9o:p1:fx15]
: mobile, perf
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Bill McCloskey (:billm)
:
:
Mentors:
Depends on: 735099
Blocks: IncrementalGC
  Show dependency treegraph
 
Reported: 2012-05-01 16:37 PDT by David Mandelin [:dmandelin]
Modified: 2012-05-10 07:59 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
patch (975 bytes, patch)
2012-05-09 15:06 PDT, Bill McCloskey (:billm)
terrence.d.cole: review+
Details | Diff | Splinter Review

Description David Mandelin [:dmandelin] 2012-05-01 16:37:35 PDT
IGC is pref'd off on Android because there was a persistent tinderbox failure. I'm marking a dep on bug 686143, but we're not sure that that was the exact problem, or that it's still a problem now. The main thing is just to get IGC going on Android.
Comment 1 Bill McCloskey (:billm) 2012-05-02 17:14:04 PDT
I just pushed to try to see if this is still a problem:
https://tbpl.mozilla.org/?tree=Try&rev=fd3d67d329f8
Comment 2 David Mandelin [:dmandelin] 2012-05-04 14:14:17 PDT
OK, this is cleared for landing (from Brad and Erin via email/in person).

Bill's not ready to re-enable it quite yet on desktop, because he wants to check out a few last issues--should take a week or so. This can go in as soon as it does on desktop, or it can even be part of the same patch. Let me know if this isn't right.
Comment 3 Bill McCloskey (:billm) 2012-05-09 15:06:45 PDT
Created attachment 622525 [details] [diff] [review]
patch
Comment 4 Terrence Cole [:terrence] 2012-05-09 15:36:07 PDT
Comment on attachment 622525 [details] [diff] [review]
patch

Review of attachment 622525 [details] [diff] [review]:
-----------------------------------------------------------------

Gross.
Comment 6 Ed Morley [:emorley] 2012-05-10 07:59:40 PDT
https://hg.mozilla.org/mozilla-central/rev/46b2b040973d

Note You need to log in before you can comment on or make changes to this bug.