Last Comment Bug 750961 - Avoid GDK_POINTER_MOTION_HINT_MASK / gdk_event_request_motions
: Avoid GDK_POINTER_MOTION_HINT_MASK / gdk_event_request_motions
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: Other Branch
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: Karl Tomlinson (back Dec 13 :karlt)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 16:45 PDT by Karl Tomlinson (back Dec 13 :karlt)
Modified: 2012-05-04 10:42 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
disable motion hints to avoid gdk_event_request_motions unless on Maemo (4.38 KB, patch)
2012-05-01 17:20 PDT, Karl Tomlinson (back Dec 13 :karlt)
roc: review+
Details | Diff | Splinter Review

Description Karl Tomlinson (back Dec 13 :karlt) 2012-05-01 16:45:52 PDT
Since GDK client side windows (GDK 2.18), GDK_POINTER_MOTION_HINT_MASK is not
implemented with X11 PointerMotionHintMask, but gdk_event_request_motions
still does a gdk_device_get_state which queries the server for state, which is
a round trip.

This code was added in bug 459780, but is not used on Mozilla builds because
of old GTK versions there.

It would make sense to disable this for desktop builds against newer GTK also, so that distributions get the same mouse behaviour.
Comment 1 Karl Tomlinson (back Dec 13 :karlt) 2012-05-01 17:20:57 PDT
Created attachment 620148 [details] [diff] [review]
disable motion hints to avoid gdk_event_request_motions unless on Maemo

This leaves the motion hints on Maemo, as X11 MotionNotify compression doesn't yet properly handle extension events (bug 459780).
Does anyone still build the GTK port for Maemo?
Comment 2 Karl Tomlinson (back Dec 13 :karlt) 2012-05-03 18:48:12 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ead1d72d499
Comment 3 Ed Morley [:emorley] 2012-05-04 10:42:10 PDT
https://hg.mozilla.org/mozilla-central/rev/4ead1d72d499

Note You need to log in before you can comment on or make changes to this bug.