Last Comment Bug 751019 - "Copy Image" does not copy the image Firefox 12
: "Copy Image" does not copy the image Firefox 12
Status: RESOLVED DUPLICATE of bug 749527
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 12 Branch
: x86_64 Windows 7
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 20:32 PDT by F W Stone
Modified: 2012-06-15 08:49 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description F W Stone 2012-05-01 20:32:57 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Have my check account display processed check image.  Right click and click "Copy Image".  


Actual results:

When the image is pasted elsewhere, there is no image.   When I go to Quicken and click "Clipboard"  the image should be placed in Quicken.  Instead, I get the location of the image.  When I try to copy other images and paste the image is not available.

This started with Firefox 12




Expected results:

The image should be pasted in the next application, if the app accepts images.
Comment 1 Demetrius Schwab 2012-05-01 20:39:35 PDT
This works for me and copying and pasting images into photoshop and other programs.
Comment 2 F W Stone 2012-05-01 21:02:28 PDT
"Copy Image" from an image in Firefox and paste it into photoshop works.
paste the same image into Thunderbird - works.

have the image displayed from my check account it will paste into photoshop.  However I cannot paste it into Thunderbird or have it copied from the clipboard with quicken.

Thunderbird provides an outline of the check with "front view of check" inside the outline.  When using quicken to copy it from the clipboard I get the following instead of the image

https://safe.bankofamerica.com/myaccounts/details/deposit/image-display.go?adx=e92913e7fd147ecfd9651abad3f7b16fda0c7b113e35bbe8ae6f6ff61dd22ebc&txn=B3L_FFPhHIBzROCUVGPcnyQyoYvHVb7KibS7S--7Vdg&face=front&index=0

I tried to save the Thunderbird message that should have contained the image and got the following message

There was a problem including the file image-display.go in the message.  Would you like to continue saving the message without this file?

While I could not save the file, I was able to send the message.  When the message arrived, it had the same outline of where the image should have been, but no image.

I do not have a problem with this type of operation with IE.
Comment 3 F W Stone 2012-05-03 22:00:27 PDT
To confirm this is a problem and not operator error, the following was done.

1.  With Firefox 12, the check image from the bank site was "Copy Image" to put it on the clipboard.
2.  Thunderbird was opened and the image pasted into a new message.  The image did not paste.  Only the outline box.  The link information as described previously appeared when this was "pasted" so the the image could be included with the check information.

3.  Firefox 12 was uninstalled and Firefox 11 installed.
4.  The image from the bank site was successfully copied and pasted into Thunderbird and quicken.  The operation functioned as expected and as it has for years.

5.  Firefox 11 was uninstalled and Firefox 12 installed.
5.  The same operations described in 1 and 2 above failed as described.

Specifically Firefox 12 has a problem that does not manifest itself in Firefox 11.  Previous versions of Firefox worked without this problem.
Comment 4 F W Stone 2012-05-04 06:43:57 PDT
New Procedure to WORK AROUND Firefox 12 NOT being able to "Copy Image"

1.  Click on bank register entry to display image on web site.  (Same as before)
2.  Right click image "View Image"  (New because of problem)  Note:  This new view or larger image does not paste either.  i.e. "Copy Image" and paste does not work properly.
3.  On the displayed image right click "Save Image As" (new because of problem)
4.  Accept or use file name to save image.  (New because of problem)
5.  In quicken click "File" and select the file with the image saved in step 4. (new because of problem)

It appears that Firefox 12 has a problem copying some images to the clipboard.  This is not true for all "Copy Image" situations.  To this point, I have only experienced the problem with check images.
Comment 5 F W Stone 2012-05-13 11:19:46 PDT
Beta 13 2 was loaded and updated 2012.05.13.  

Beta 13 exhibites the same problem as 12 of NOT being able to copy the image to the clipboard in a manner that can be pasted into Thunderbird (HTML mode) or Quicken.
Comment 6 F W Stone 2012-05-16 10:29:30 PDT
Firefox 13.0b3 was installed.  The failure continued to occur.

As a test, "Copy Image" using Firefox 11 was used and pasted into Thunderbird on Vista.  It worked.  Firefox on the Vista system was updated to Firefox 12 and it failed to paste the image into Thunderbird.
Comment 7 F W Stone 2012-05-19 19:14:08 PDT
Firefox 13.0b4 was installed.  The failure continues to occur.

Additional tests were conducted, copying from other secure sites with no difficulty.  The only failure seems to be when copying the check image of a processed check.  The Image cannot be pasted into Thunderbird or Quicken.

As I have said before, the problem began with Firefox 12.
Comment 8 David E. Ross 2012-05-26 17:30:17 PDT
Windows XP SP3
Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20120429 SeaMonkey/2.9.1

This is not only a Firefox bug.  I see it with SeaMonkey.  It might be a Gecko or Toolkit bug, or it might be a Windows problem.  

I hover my cursor over a JPEG image at <http://www.rossde.com/garden/garden_bloom.html> and select Copy Image from the pull-down context menu.  I then paste the image in Paint, Photo Editor, or IconEdit 32.  That is successful.  

If I attempt to paste the image in Word or Wordpad, however, the URI of the image is pasted.  Pasting is disabled if I attempt to paste the image in PhotoStudio 2000.
Comment 9 F W Stone 2012-05-26 20:55:06 PDT
Firefox 13.0b5 was installed.  The failure continues to occur.
Comment 10 Alice0775 White 2012-06-15 08:49:55 PDT
WFM
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0 ID:20120601045813

*** This bug has been marked as a duplicate of bug 749527 ***

Note You need to log in before you can comment on or make changes to this bug.