DirectWrite off on 50% of windows 7 machines

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
5 years ago
3 years ago

People

(Reporter: u295173, Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I created a littele Javascript that checks if DirectWrite subpixel positioning is active in your browser.
It works by comparing the width of a div at a small font size to the width of a div at large font sizes.
I ran the test on multiple websites with thousands of visitors.

Check the script here:
http://jossele.de/font-direct-write-detect.html



Actual results:

I realised that DirectWrite (with subpixel positioning) in Firefox is only activated on 4% of the Windows 7 machines.


Expected results:

It should be activated on much more machines to have consitent rendering and more people benefit from better text rendering.
(Reporter)

Updated

5 years ago
(Reporter)

Updated

5 years ago
OS: Windows XP → Windows 7
Hardware: x86 → x86_64
(Reporter)

Comment 1

5 years ago
For information what i mean with subpixel positioning, see this post:
http://blog.mozilla.org/nattokirai/2011/08/11/directwrite-text-rendering-in-firefox-6/

Comment 2

5 years ago
I have a Windows 7 machine with DirectWrite enabled and yet your script displays DirectWrite subpixel positioning: false

I think you need to choose a different font to Verdana as by default that is in the default gfx.font_rendering.cleartype_params.force_gdi_classic_for_families list.
(Reporter)

Comment 3

5 years ago
Ok. Thanks! I just realised this. I will check it and write again in a few minutes. Sorry!

Comment 4

5 years ago
Returns true now you've changed it so you need to start your survey again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

5 years ago
Ok. Now with different fonts I detect that DirectWrite is on on approximately 50% of the machines. Much better but than my previous results but still not perfect. Is this because of blacklisting of old drivers?
IE9 has 99% here!

Now I could close the bug or ask you guys to consider enabling it on more machines... But I guess you already considered that.
(Reporter)

Updated

5 years ago
Summary: DirectWrite off on 96% of windows 7 machines → DirectWrite off on 50% of windows 7 machines

Updated

5 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Hello,

I try to cleanup old bugs, so i found this one.
do you have new values on this?
because 2 years goes on and i think there was some updates for this.
maybe we can finaly close it already?

thanks for your help.
Flags: needinfo?(jossele)
Closed -> no feedback from reporter.

please feel free to reopen this report if you have new or additional information.
thank you for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago3 years ago
Flags: needinfo?(jossele)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.