Intermittent Leak in browser/devtools/debugger/test/browser_dbg_bug731394_editor-contextmenu.js

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Bobby Holley (parental leave - send mail for anything urgent), Unassigned)

Tracking

({intermittent-failure, mlk})

Firefox Tracking Flags

(Not tracked)

Details

I couldn't find a bug on this. Let me know if it's a dupe.

We're reliably leaking 22 objects during browser-chrome on mozilla-central right now, but the leak threshold is set to 23. I did some digging, and it looks like we do things that way because we've got the following intermittent leak:

[browser/devtools/debugger/test/browser_dbg_bug731394_editor-contextmenu.js]
  1 window(s) [url = http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-switching.html]

See:
https://tbpl.mozilla.org/php/getParsedLog.php?id=11372323&tree=Firefox&full=1

which is the osx debug mochitest-o run for:
https://tbpl.mozilla.org/?rev=d3a3b430e951

Updated

6 years ago
Blocks: 658738

Updated

6 years ago
Keywords: mlk

Updated

6 years ago
Blocks: 731394
Priority: -- → P3

Updated

6 years ago
Blocks: 754804
No longer blocks: 754804
Blocks: 754804

Comment 1

5 years ago
Bug 772388 means this needs to show up on [orange]/sw:randomorange searches; adding.
Blocks: 438871
Whiteboard: [orange]

Comment 2

5 years ago
Actually, there is already bug 770542.
No longer blocks: 438871, 658738, 754804, 731394
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [orange]
Duplicate of bug: 770542

Comment 3

5 years ago
Breaking out from bug 770542 again.

(In reply to Ryan VanderMeulen from comment #183)
> (In reply to TinderboxPushlog Robot from comment #182)
> > ryanvm%gmail.com
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=13755727&tree=Mozilla-
> > Inbound
> > Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-other on
> > 2012-07-22 07:57:10
> > slave: talos-r4-snow-017
> > 
> > TEST-UNEXPECTED-FAIL | ShutdownLeaks | leaked 4 DOMWindow(s) and 1
> > DocShell(s) until shutdown
> > TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js |
> > leaked 1 window(s) until shutdown [url =
> > chrome://browser/content/tabview.html]
> > TEST-UNEXPECTED-FAIL | browser/base/content/test/browser_bug597218.js |
> > leaked 1 docShell(s) until shutdown
> > TEST-UNEXPECTED-FAIL |
> > browser/components/places/tests/browser/browser_views_liveupdate.js | leaked
> > 1 window(s) until shutdown [url = about:blank]
> > TEST-UNEXPECTED-FAIL |
> > browser/devtools/debugger/test/browser_dbg_bug731394_editor-contextmenu.js |
> > leaked 1 window(s) until shutdown [url =
> > http://example.com/browser/browser/devtools/debugger/test/browser_dbg_script-
> > switching.html]
> > TEST-UNEXPECTED-FAIL |
> > toolkit/components/social/test/browser/browser_frameworker.js | leaked 1
> > window(s) until shutdown [url = about:blank]
> 
> This was on an inbound push from today. And yes, m-c is in sync with inbound
> with respect to the patch for this bug.


(In reply to Victor Porof from comment #184)
> Unfortunately, a lot of other leaking tests have been aggregated into this
> one, although the causes for each one were different.
> 
> In the logs, I see only browser_dbg_bug731394_editor-contextmenu.js leaking
> in mozilla-inbound, while the other leaks occur only on aurora (where the
> patch hasn't landed yet).
> 
> Let's keep an eye on this and see if the breakpoint specific tests still
> leak on the trees untouched by the patch.
Blocks: 438871, 658738, 754804
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Hasn't shown up after bug 728294 landed, so going to call this a false positive and mark WFM for now.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.