Last Comment Bug 751176 - OMTC Linux: Canvas and Video blinks when using OMTC and layers acceleration on Linux
: OMTC Linux: Canvas and Video blinks when using OMTC and layers acceleration o...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: Other Branch
: All Linux
: -- normal with 1 vote (vote)
: mozilla15
Assigned To: Nicolas Silva [:nical]
:
:
Mentors:
Depends on:
Blocks: 722012 751180
  Show dependency treegraph
 
Reported: 2012-05-02 07:55 PDT by Nicolas Silva [:nical]
Modified: 2013-09-20 06:03 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fixes blinking of video and canvas elements with OMTC on Linux. (1.67 KB, patch)
2012-05-04 10:31 PDT, Nicolas Silva [:nical]
jmuizelaar: review+
Details | Diff | Splinter Review

Description Nicolas Silva [:nical] 2012-05-02 07:55:22 PDT
To enable OMTC on Linux: 
 - apply attachment 618255 [details] [diff] [review] from bug 722012 (not landed yet)
 - set the environment variable MOZ_USE_OMTC
 - set the pref layers.acceleration.force-enabled to true

Videos such as http://www.mozilla.org/en-US/firefox/11.0/whatsnew/ blink as well as canvas games like http://canvasrider.com/tracks/random or http://superbitboy.com/ .

The bad behaviour is similar for canvas and video so I opened only one bugzilla entry, maybe they do need separate bugs.
Comment 1 Nicolas Silva [:nical] 2012-05-04 10:31:15 PDT
Created attachment 621094 [details] [diff] [review]
Fixes blinking of video and canvas elements with OMTC on Linux.

OnExposeEvent was not handled correctly in the case of OMTC. I think this fix is important because other OMTC-related fixes will most likely depend on it.

Needs attachment 618255 [details] [diff] [review].
Comment 2 Nicolas Silva [:nical] 2012-05-04 10:45:21 PDT
Attachment 621094 [details] [diff] seems to also fix bug 751180.
Comment 3 Constantine 2012-05-04 23:48:43 PDT
(In reply to Nicolas Silva [:nical] from comment #2)
> Attachment 621094 [details] [diff] seems to also fix bug 751180.
Yes, it fixes WebGL and all blinking for me but only with gfx.xrender.enabled=false. With xrender enabled the patch doesn't fix anything. The problem is probably NVidia-specific.
Comment 4 Nicolas Silva [:nical] 2012-05-05 13:42:12 PDT
(In reply to konstartyom from comment #3)
> (In reply to Nicolas Silva [:nical] from comment #2)
> > Attachment 621094 [details] [diff] seems to also fix bug 751180.
> Yes, it fixes WebGL and all blinking for me but only with
> gfx.xrender.enabled=false. With xrender enabled the patch doesn't fix
> anything. The problem is probably NVidia-specific.

It also still blinks if xrender is enabled on my laptop (intel integrated gpu).
Comment 5 Nicolas Silva [:nical] 2012-05-15 12:14:56 PDT
It is very likely that we just don't try to support xrender with omtc. Right now the tendency is to get rid of xrender anyway.
Comment 6 Jeff Muizelaar [:jrmuizel] 2012-05-28 08:30:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ecd6235510e1
Comment 7 Ed Morley [:emorley] 2012-05-29 10:22:59 PDT
https://hg.mozilla.org/mozilla-central/rev/ecd6235510e1

Note You need to log in before you can comment on or make changes to this bug.