Convert DOMUserData to WeakMaps in debugger code

RESOLVED DUPLICATE of bug 707302

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED DUPLICATE of bug 707302
6 years ago
6 years ago

People

(Reporter: past, Assigned: vporof)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Bug 749981 will remove getUserData and setUserData. The two instances where we use these two functions in browser/devtools/debugger/debugger-controller.js and browser/devtools/debugger/debugger-view.js should be replaced by WeakMaps, as suggested in bug 723062 comment 36.
(Assignee)

Comment 1

6 years ago
I'm not sure if we actually need WeakMaps here. A trivial temporary workaround would just be attaching the script data as a property to the object (not sure why we used setUserData in the first place, reading through the code now I don't see a convincing reason, maybe I'm wrong), with a glorified ulterior fix in bug 707302.
(Assignee)

Updated

6 years ago
Assignee: nobody → vporof
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 707302
You need to log in before you can comment on or make changes to this bug.