Horizontal scroll doesn't appear when jQuery UI datepicker used

RESOLVED FIXED in Firefox 13

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Adam Carheden, Assigned: mats)

Tracking

({regression, reproducible})

12 Branch
mozilla15
x86_64
All
regression, reproducible
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox13- verified, firefox14- verified, firefox15+ verified)

Details

(Whiteboard: [fixed by bug 749935][qa+])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 620404 [details]
ff12_datepicker.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Viewed the attached ff12_datepicker.html


Actual results:

Horizontal scroll bar didn't appear even though table overflowed page width until one of the jQuery datepicker elements was activated.

Viewed same page in Chrome, IE and FF11. Paged worked as expected in those browsers.


Expected results:

Horizontal scroll bar should have appeared when page loaded.

This is possibly a dupe of 750323.

Updated

5 years ago
Attachment #620404 - Attachment mime type: text/plain → text/html

Comment 1

5 years ago
Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/0b4c58200e3a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 ID:20120117042508
Fails:
http://hg.mozilla.org/mozilla-central/rev/ff1bedd7d463
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 ID:20120117072408
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b4c58200e3a&tochange=ff1bedd7d463

Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7ea3311b5e6c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120116 Firefox/12.0a1 ID:20120116145408
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3077b729dfd5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120116 Firefox/12.0a1 ID:20120116153908
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7ea3311b5e6c&tochange=3077b729dfd5


Last good: 804c80adda0a
First bad: 87536f378706
Blocks: 665597
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Firefox → Core
QA Contact: untriaged → layout
Requesting tracking for the regression....
tracking-firefox13: --- → ?
tracking-firefox14: --- → ?
tracking-firefox15: --- → ?
status-firefox13: --- → affected
status-firefox14: --- → affected
status-firefox15: --- → affected
tracking-firefox13: ? → +
tracking-firefox14: ? → +
tracking-firefox15: ? → +

Comment 3

5 years ago
roc - can you find an assignee for this reproducible regression? Thanks!
Assignee: nobody → roc
Keywords: reproducible
(Assignee)

Comment 4

5 years ago
I'll take a look...
Assignee: roc → matspal
(Assignee)

Comment 5

5 years ago
Created attachment 622178 [details]
Testcase

The jquery.datepicker script inserts a <div> with style:
.ui-helper-hidden-accessible { position: absolute; left: -99999999px; }

Reducing the left offset by a magnitude makes the scrollbar display.

So this is basically a dupe of bug 749935.
(Assignee)

Updated

5 years ago
Depends on: 749935
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed by bug 749935]
Target Milestone: --- → mozilla15

Updated

5 years ago
status-firefox15: affected → fixed
untracking in favour of bug 749935 which is awaiting nominations for landing to beta/aurora.
tracking-firefox13: + → -
tracking-firefox14: + → -
(Assignee)

Updated

5 years ago
Duplicate of this bug: 754247

Comment 8

5 years ago
The patch of bug 749935 landed in 13.0 and 14.0.
status-firefox13: affected → fixed
status-firefox14: affected → fixed
Whiteboard: [fixed by bug 749935] → [fixed by bug 749935][qa+]
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0

Verified using attachment test case in Ubuntu 12.04, Mac OS 10.6, Windows 7. Firefox 13 beta 6. Horizontal bar is displayed as expected.
status-firefox13: fixed → verified

Comment 10

5 years ago
I've just experienced this as well. Use of jQuery UI Datepicker on page, prevents Firefox from displaying horizontal scrollbar -- needed in this app's UI for viewing/editing a very wide table.

Thanks 'iop' for his CSS patch;  reducing the magnitude  of 'negative left hiding' to -9999999, rather than -99999999  (7 nines rather than 8).
Thomas, what build did you test? This is supposed to be fixed now in Firefox 13.0b6, latest-mozilla-aurora, and latest-mozilla-central. It is not fixed in Firefox 12 and earlier, nor will it be.
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20120614 Firefox/15.0a2
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0

Verified using attachment test case on Firefox 14b7, Aurora on Ubuntu 12.04, Mac OS 10.6, Windows XP. Horizontal bar is displayed.
status-firefox14: fixed → verified
status-firefox15: fixed → verified

Comment 13

5 years ago
Hi Anthony, yes that was at 12.  Just letting you know this is occuring in the wild; JQuery components use these large -ve positions to hide, so the bug is relevant to a good number of users.
You need to log in before you can comment on or make changes to this bug.