Last Comment Bug 751286 - eventPhase NONE constant
: eventPhase NONE constant
Status: RESOLVED FIXED
Opera: CORE-46127
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 11:49 PDT by Anne (:annevk)
Modified: 2012-05-03 04:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.12 KB, patch)
2012-05-02 12:54 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review
patch (4.25 KB, patch)
2012-05-02 14:24 PDT, Olli Pettay [:smaug]
jonas: review+
Details | Diff | Splinter Review

Description Anne (:annevk) 2012-05-02 11:49:32 PDT
To address https://www.w3.org/Bugs/Public/show_bug.cgi?id=16335 we added a new constant to DOM4 for eventPhase. We should add that and align our default value with Safari/Chrome/IE.
Comment 1 Olli Pettay [:smaug] 2012-05-02 11:58:26 PDT
I guess this is ok (though returning 2 is IMO ok too).
Comment 3 Olli Pettay [:smaug] 2012-05-02 14:16:55 PDT
Looks like I need to update one smil test
Comment 5 Olli Pettay [:smaug] 2012-05-03 04:01:49 PDT
https://hg.mozilla.org/mozilla-central/rev/b4d2343fff9d

Note You need to log in before you can comment on or make changes to this bug.