Closed Bug 751297 Opened 8 years ago Closed 8 years ago

Many web pages jump to middle or bottom in ver 12.0

Categories

(Firefox :: Untriaged, defect)

11 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 748803

People

(Reporter: webmonster54-firefox, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Upgraded to Firefox version 12.0.  Visited many web pages.


Actual results:

Some web pages jumped to the middle or bottom of the page when rendered in Firefox 12.0. One example page was www.landsend.com.  Problem did not happen in other browser on same computer. Reverted to Firefox ver 11.0 and problem went away.


Expected results:

Pages should display at the top when first rendered.
5/17/12
This happens on all NewEgg and eBay product listing pages, and many other e-commerce and user forum sites, even Mozilla  It seems to jump to a spot on the page where there is a Javascript user input box, or clickable link.  Somehow, FF v 12 is reading something in the Javascript code as a "goTo" on these pages, when in fact it is not supposed to be rendered that way.
FF has been started in Safe Mode, all add-ons and extensions disabled, with no luck.  The only thing that cures this is reversion of FF v 11.
 
--Mr. News
It's been discovered that removing or de-activating a user's MVPS-supplied HOSTS file causes this problem to disappear in FF v. 12.  The MVPS HOSTS file website is located at:
http://winhelp2002.mvps.org/hosts.htm

People using the MVPS HOSTS file are unwilling to give it up to continue using Firefox, as this HOSTS file provides an excellent layer of protection from scammy ads and virus-laden auto-downloads attached to them.  
This problem first appeared in FF v. 12, and did not exist before.  Some domain(s) being blocked by the HOSTS file is interacting with Firefox to cause the page jumps on many sites.  Again, this problem does NOT currently exist with IE or Chrome.
This appears to be caused by the fix for Bug 301471: https://bugzilla.mozilla.org/show_bug.cgi?id=301471

The MVPS HOSTS file redirects hosts for various tracking services to 127.0.0.1. When the redirected URL is the src of an iframe, Firefox fills the iframe with the netError page. Starting in Firefox 12, the Try Again button in that frame is focused, causing the page to scroll so that the button comes into view.

When an iframe is hidden by being set to zero width, zero height, this is not apparent, but as far as I can tell, that is what's happening.

If possible, the autofocus should not be set in an iframe, or at least not in an iframe that is too small for the button to be visible.
Bug 748803 fixed this, precisely by not autofocusing error pages in iframes.  Fix should be in Firefox 13.

Mr. News, Jefferson, thanks for pinning this down!
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748803
You need to log in before you can comment on or make changes to this bug.