Last Comment Bug 751334 - Redundant TabView.init call in restoreWindow leaks the browser window when the window closes before delayedStartup was called. (browser_514751.js)
: Redundant TabView.init call in restoreWindow leaks the browser window when th...
Status: RESOLVED FIXED
: mlk
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Dão Gottwald [:dao]
:
: Mike de Boer [:mikedeboer]
Mentors:
Depends on:
Blocks: 627642 bc-leaks 734155 752456
  Show dependency treegraph
 
Reported: 2012-05-02 13:28 PDT by Dão Gottwald [:dao]
Modified: 2012-05-14 17:55 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.68 KB, patch)
2012-05-02 13:28 PDT, Dão Gottwald [:dao]
ttaubert: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-05-02 13:28:02 PDT
Created attachment 620452 [details] [diff] [review]
patch

A redundant TabView.init call in restoreWindow leaks the browser window when the window closes before delayedStartup was called, since we only call TabView.uninit when delayedStartup was called. The extra TabView.init call shouldn't be needed, since browser-tabview.js listens for SSWindowStateReady.
Comment 1 Dão Gottwald [:dao] 2012-05-02 13:30:28 PDT
The leak shows up here:

[browser/components/sessionstore/test/browser_514751.js]
  1 window(s) [url = chrome://browser/content/browser.xul]
  1 window(s) [url = about:blank]
Comment 2 Tim Taubert [:ttaubert] 2012-05-04 09:09:16 PDT
Comment on attachment 620452 [details] [diff] [review]
patch

Review of attachment 620452 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, thanks for spotting this. We indeed don't need this anymore now that we listen for SSWindowStateReady.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-05-05 03:39:07 PDT
https://hg.mozilla.org/mozilla-central/rev/d5571baeb933

Note You need to log in before you can comment on or make changes to this bug.