Last Comment Bug 751370 - Do not use accelerated layers for small popups windows on Linux
: Do not use accelerated layers for small popups windows on Linux
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: Nicolas Silva [:nical]
:
Mentors:
Depends on:
Blocks: 758048
  Show dependency treegraph
 
Reported: 2012-05-02 14:30 PDT by Nicolas Silva [:nical]
Modified: 2012-05-23 15:56 PDT (History)
7 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Disables layers acceleration for small popups like menus and combo boxes. (1022 bytes, patch)
2012-05-03 07:44 PDT, Nicolas Silva [:nical]
bgirard: review+
Details | Diff | Review
Disables layers acceleration for small popups like menus and combo boxes. (1022 bytes, patch)
2012-05-05 13:33 PDT, Nicolas Silva [:nical]
bgirard: review+
Details | Diff | Review

Description Nicolas Silva [:nical] 2012-05-02 14:30:13 PDT
Right now on Linux, either all windows are accelerated or none. We don't need to accelerate small popup windows such as menus. It is not extremely important but it would help debugging GLContext related problems.
Comment 1 Nicolas Silva [:nical] 2012-05-03 07:44:23 PDT
Created attachment 620698 [details] [diff] [review]
Disables layers acceleration for small popups like menus and combo boxes.

This patch feels almost too simple. Is it worth adding a pref (something like layers.acceleration.accelerate-popups)? I don't see why we would want accelerated layers for these windows...
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-05-03 09:24:52 PDT
(In reply to Nicolas Silva [:nical] from comment #1)
> Created attachment 620698 [details] [diff] [review]
> Disables layers acceleration for small popups like menus and combo boxes.
> 
> This patch feels almost too simple. Is it worth adding a pref (something
> like layers.acceleration.accelerate-popups)? I don't see why we would want
> accelerated layers for these windows...

I do not think it's worth adding a pref.
Comment 3 Nicolas Silva [:nical] 2012-05-05 13:33:33 PDT
Created attachment 621340 [details] [diff] [review]
Disables layers acceleration for small popups like menus and combo boxes.

Fixed a stupid mistake in the previous attachment. This one works.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-05-06 17:36:25 PDT
https://hg.mozilla.org/mozilla-central/rev/96451c3a2511
Comment 6 Justin Dolske [:Dolske] 2012-05-06 19:02:18 PDT
Hmm, will this also affect XUL <panel>s?

nsWidgetInitData.h seems to imply that it will (nsPopupType panel)... I'd suspect that we still want those accelerated since they can hold arbitrarily complex stuff...
Comment 7 Neil Deakin 2012-05-07 04:04:23 PDT
(In reply to Justin Dolske [:Dolske] from comment #6)
> Hmm, will this also affect XUL <panel>s?
> 

It will.
Comment 8 Nicolas Silva [:nical] 2012-05-07 10:35:36 PDT
Should we back this patch out?

I don't know what a xul panel is.
It looks like this problem could be solved by making GetShouldAccelerate vertual and overriding it in nsWindow taking into account the type of the popup using with nsWindow::PopupType().

I can do this if someone backs the patch out, or fix it as another patch on top of it.

Are there other popup types that we would want to accelerate ?
Comment 9 Justin Dolske [:Dolske] 2012-05-23 15:56:41 PDT
I (obviously) just filed bug 758048 for the <panel> issue. I don't think a backout is needed, but we should fix it at some point. Seems like an easy fix anyway? (hint hint:)

Note You need to log in before you can comment on or make changes to this bug.