Last Comment Bug 751425 - shell exit code for runtime error differs between -e and -f
: shell exit code for runtime error differs between -e and -f
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- minor (vote)
: mozilla15
Assigned To: Steve Fink [:sfink] [:s:]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 17:03 PDT by Jesse Ruderman
Modified: 2012-05-25 08:28 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix JS shell exit status on -e script failure (1.06 KB, patch)
2012-05-07 12:26 PDT, Steve Fink [:sfink] [:s:]
jimb: review+
Details | Diff | Splinter Review

Comment 1 Steve Fink [:sfink] [:s:] 2012-05-07 12:26:06 PDT
Created attachment 621684 [details] [diff] [review]
Fix JS shell exit status on -e script failure

I think EXIT_FAILURE is intended to only be used for the shell machinery (argument parsing, etc.); any actual JS error should be EXITCODE_RUNTIME_ERROR (or one of the more specific ones.)
Comment 2 Steve Fink [:sfink] [:s:] 2012-05-24 20:56:12 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3656a0a559b2
Comment 3 Ed Morley [:emorley] 2012-05-25 08:28:39 PDT
https://hg.mozilla.org/mozilla-central/rev/3656a0a559b2

Note You need to log in before you can comment on or make changes to this bug.