Can't reload the page after clearing private data

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
9 months ago

People

(Reporter: Paul Feher, Assigned: Margaret)

Tracking

({reproducible})

Trunk
Firefox 15
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed, blocking-fennec1.0 +)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Nightly Fennec 15.0a1 (2012-05-02)
Aurora Fennec 14.0a2 (2012-05-02)
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
1. Load any page (Ex. yahoo.com).
2. Clear private data from Menu>More>Settings>.
3. Go back and reload the page.

Expected result:
The page is reloaded.

Actual result:
Nothing happens when tapping the reload button.
(Reporter)

Updated

5 years ago
status-firefox14: --- → affected
status-firefox15: --- → affected
Reproduced.

--
Nightly (05/03)
Samsung Galaxy Nexus (Android 4.0.4)
blocking-fennec1.0: --- → ?

Updated

5 years ago
Keywords: regression, reproducible
Assignee: nobody → margaret.leibovic
blocking-fennec1.0: ? → +
(Assignee)

Comment 2

5 years ago
Created attachment 620827 [details] [diff] [review]
patch

There's no need to check for whether or not there's history when doing a reload call. The "Session:Reload" message just ends up calling browser.reload():
http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/browser.js#925

Also, these methods in Tab and their corresponding methods in GeckoApp are all returning booleans, but we don't end up actually doing anything with them... Also, there seems to be a lot of redundancy there - the methods in GeckoApp all get the selected tab, then just call the corresponding method in Tab. Oh well, maybe we can fix that some other time.
Attachment #620827 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

5 years ago
This wasn't a regression.
Keywords: regression
Attachment #620827 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/fa7094b8282d
Target Milestone: --- → Firefox 15

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/fa7094b8282d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

5 years ago
Verified fixed on:
Nightly Fennec 15.0a1 (2012-05-06)
Device: HTC Desire Z
OS: Android 2.3.3

Using the initial STR.
Status: RESOLVED → VERIFIED
status-firefox15: affected → fixed
(Assignee)

Comment 7

5 years ago
Comment on attachment 620827 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: reload doesn't work after clearing private data
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low-risk, mobile-only, just removes unnecessary check
String changes made by this patch: n/a
Attachment #620827 - Flags: approval-mozilla-aurora?
Attachment #620827 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/4de94a39aef2
status-firefox14: affected → fixed
You need to log in before you can comment on or make changes to this bug.