Last Comment Bug 751511 - Remove -fno-common flag
: Remove -fno-common flag
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: jemalloc3
  Show dependency treegraph
 
Reported: 2012-05-03 03:14 PDT by Mike Hommey [:glandium]
Modified: 2012-05-04 13:37 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't use the -fno-common flag (1.07 KB, patch)
2012-05-03 03:16 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Don't use the -fno-common flag (1.05 KB, patch)
2012-05-03 08:46 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-05-03 03:14:59 PDT
AFAICS from the CVS history, -fno-common has been there on OSX only since the 2000, when the build was made to work on OSX. I see no reason to keep it, especially considering we don't use the flag on other platforms. It also breaks my jemalloc3 queue because I rely on -fcommon to override jemalloc overridable variables (thus avoiding modifying jemalloc upstream source code and possible future merge conflicts). I could remove -fno-common when building jemalloc only, but I don't think it hurts to just remove it completely.
Comment 1 Mike Hommey [:glandium] 2012-05-03 03:16:39 PDT
Created attachment 620635 [details] [diff] [review]
Don't use the -fno-common flag
Comment 2 Mike Hommey [:glandium] 2012-05-03 08:46:04 PDT
Created attachment 620718 [details] [diff] [review]
Don't use the -fno-common flag
Comment 4 :Ehsan Akhgari (away Aug 1-5) 2012-05-04 13:37:09 PDT
https://hg.mozilla.org/mozilla-central/rev/5854da577bcb

Note You need to log in before you can comment on or make changes to this bug.