Last Comment Bug 751567 - [comm-central, Windows] "js\src\gc/Root.h(303) : fatal error C1075: end of file found before the left brace '{' at '[...]/js/src/jsnum.cpp(1232)' was matched"
: [comm-central, Windows] "js\src\gc/Root.h(303) : fatal error C1075: end of fi...
Status: VERIFIED FIXED
[fixed by bug 745742]
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows Server 2003
: P1 blocker (vote)
: mozilla15
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 745742
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 07:39 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-05-04 14:37 PDT (History)
3 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Serge Gautherie (:sgautherie) 2012-05-03 07:39:30 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1336006782.1336016681.30684.gz
WINNT 5.2 comm-central-trunk leak test build on 2012/05/02 17:59:42
using revisions: comm-central/01e0db038845, mozilla-central/d624dbe9e0c6
+
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1336014146.1336016157.30045.gz
WINNT 5.2 comm-central leak test build on 2012/05/02 20:02:26
using revisions: comm-central/01e0db038845, mozilla-central/a8c16e7b819b

Good.


http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1336022437.1336022966.8121.gz
WINNT 5.2 comm-central-trunk leak test build on 2012/05/02 22:20:37
using revisions: comm-central/01e0db038845, mozilla-central/807403a04a6a
+
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1336017918.1336018422.799.gz
WINNT 5.2 comm-central leak test build on 2012/05/02 21:05:18
using revisions: comm-central/01e0db038845, mozilla-central/807403a04a6a
{
e:\builds\slave\comm-cen-trunk-w32-dbg\build\mozilla\js\src\gc/Root.h(303) : fatal error C1075: end of file found before the left brace '{' at 'e:/builds/slave/comm-cen-trunk-w32-dbg/build/mozilla/js/src/jsnum.cpp(1232)' was matched
}

Broken.
Comment 1 Justin Wood (:Callek) 2012-05-03 14:39:15 PDT
So looking at the blame list for this file, and seeing the very large regression range (in num of csets), this looks like you Brian.

My initial theory is that this is failing with MSVC8 and would succeed with MSVC10, does that sound likely, or is it simply a clobber, or "what". Staring at this code you added [in mxr] makes me wonder what could be broken to cause this though.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-05-03 19:32:29 PDT
I landed a patch which disabled the jsnum.cpp code fingered by the error message, in MSVC compilers only.  It's not the right fix that does the root-checking intended here, but it makes things compile again, which as I could find no legitimate workaround seems like a second-best thing in the short run.

https://hg.mozilla.org/integration/mozilla-inbound/rev/4608e8e96c87
Comment 3 Serge Gautherie (:sgautherie) 2012-05-04 14:37:23 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1336145498.1336156317.28695.gz
WINNT 5.2 comm-central-trunk leak test build on 2012/05/04 08:31:38

V.Fixed, by bug 745742 comment 9.

Note You need to log in before you can comment on or make changes to this bug.