Last Comment Bug 751641 - Flash player does not start (all plugins have a Java MIME type added)
: Flash player does not start (all plugins have a Java MIME type added)
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 15 Branch
: x86 Windows 7
: -- major with 2 votes (vote)
: mozilla15
Assigned To: Josh Aas
:
Mentors:
: 752128 752173 752338 (view as bug list)
Depends on:
Blocks: 733322 748343 753129
  Show dependency treegraph
 
Reported: 2012-05-03 10:58 PDT by Alice0775 White
Modified: 2012-05-08 14:55 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (3.04 KB, patch)
2012-05-03 11:48 PDT, Josh Aas
jst: review+
Details | Diff | Splinter Review
pluginreg.dat (685 bytes, text/plain)
2012-05-03 11:53 PDT, Masatoshi Kimura [:emk]
no flags Details

Description Alice0775 White 2012-05-03 10:58:24 PDT
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/807403a04a6a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120503030512

Flash player does not start if one of plugins disabled.

Delete pluginreg.dat from profile folder helps

Reproducible: Always

Steps to Reproduce:
1. You should install Flash Plugin and several plugins such as Acrobat Acrobat, SilverLight, Google Earth, Java(TM) Platform SE 6 U32 with clean profile.
2. Start Firefox
3. Open Youtube Flash Video http://www.youtube.com/watch?v=55s3T7VRQSc and Confirm play
4. Open Addon Manager and Disable one of plugins(such as Acrobat Acrobat)
5. Restart Firefox
6. Open Youtube Flash Video http://www.youtube.com/watch?v=55s3T7VRQSc again

Actual Results:
  Flash Player does not start

Expected Results:
  Flash Player should start


Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/a8c16e7b819b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120502195801
Fails:
http://hg.mozilla.org/mozilla-central/rev/807403a04a6a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120503030512
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a8c16e7b819b&tochange=807403a04a6a


Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/83ff77ce8d6c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120501120141
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c3813fbb1c9a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120501134841
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=83ff77ce8d6c&tochange=c3813fbb1c9a

Regressed by:
813fbb1c9a	Josh Aas — Bug 748343: Remove support for "java" and "packages" objects from the DOM. r=jst sr=smaug a=ehsan CLOSED TREE



Java(TM) Platform SE 6 U32 
    Version: 6.0.320.5

Java Deployment Toolkit 6.0.320.5
    Version: 6.0.320.5

Google Earth Plugin
    Version: 6.2.0.5788

Shockwave Flash
    Version: 11.2.202.233

Adobe Acrobat
    Version: 10.1.3.23

Google Update
    Version: 1.3.21.111

VLC Web Plugin
    Version: 2.0.0.0

Silverlight Plug-In
    Version: 5.0.61118.0

QuickTime Plug-in 7.7.1
    Version: 7.7.1.0

Windows Genuine Advantage
    Version: 1.9.9.1

Microsoft® Windows Media Player Firefox Plugin
    Version: 1.0.0.8

ATOK
    Version: 19.0.3.0
Comment 1 Alice0775 White 2012-05-03 11:00:40 PDT
Step 4. Open Addon Manager and Disable one of plugins(such as Acrobat Acrobat)
Maybe not necessary.
Comment 2 Masatoshi Kimura [:emk] 2012-05-03 11:39:30 PDT
> +      // This used to depend on whether or not we had an npruntime-enabled
> +      // Java plugin but we don't care any more, we just assume we do.
> +      PR_fprintf(fd, "%d%c%s%c%s%c%s%c%c\n",
> +        tag->mMimeTypes.Length(), PLUGIN_REGISTRY_FIELD_DELIMITER,
> +        "application/x-java-vm-npruntime",
> +        PLUGIN_REGISTRY_FIELD_DELIMITER,
> +        "",
> +        PLUGIN_REGISTRY_FIELD_DELIMITER,
> +        "",
> +        PLUGIN_REGISTRY_FIELD_DELIMITER,
> +        PLUGIN_REGISTRY_END_OF_LINE_MARKER);
Now this code is executed even if the plugin is not Java. Is it correct?
Comment 3 Josh Aas 2012-05-03 11:48:46 PDT
Created attachment 620795 [details] [diff] [review]
fix v1.0

This fixes part of the problem with my patch re: pluginreg.dat. Still need to verify that this fixes the reporter's problem here.
Comment 4 Masatoshi Kimura [:emk] 2012-05-03 11:53:37 PDT
Created attachment 620799 [details]
pluginreg.dat

> 0|application/x-vnd.google.update3webcontrol.3|||$
> 1|application/x-vnd.google.oneclickctrl.9|||$
> 2|application/x-java-vm-npruntime|||$
The last line was not present before bug 748343. Obviously Google Update is not a Java plug-in.
Comment 5 Josh Aas 2012-05-03 12:19:48 PDT
Comment on attachment 620795 [details] [diff] [review]
fix v1.0

Review of attachment 620795 [details] [diff] [review]:
-----------------------------------------------------------------

Fixes the problem for me. We don't want to add that Java NPRuntime MIME type to all cached plugin MIME lists (my bad) and we don't need to ignore it in the active MIME list either.
Comment 6 Josh Aas 2012-05-03 12:31:29 PDT
Try server run:

https://tbpl.mozilla.org/?tree=Try&rev=6c70e151f6c3
Comment 7 Josh Aas 2012-05-03 21:37:18 PDT
pushed to mozilla-inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/e53c3fb93f8b
Comment 8 Karl Tomlinson (:karlt) 2012-05-03 21:44:31 PDT
Setting mIsJavaPlugin was causing the plugin to run in the browser process.
Comment 9 CruNcher 2012-05-04 10:03:59 PDT
Though this seems to not affect everyone for my personal profile it's no problem only for a default new profile in my case it turns black and i also have a pluginreg.dat and disabled some plugins in that profile.
Comment 10 CruNcher 2012-05-04 10:08:49 PDT
Ah nope i had no plugin disabled in my list now i test wise disabled one and after restart no flash playback possible re enabling also doesn't help anymore the profile is practically damaged now and only deleting pluginreg.dat restores it :(
Comment 11 Josh Aas 2012-05-04 11:45:57 PDT
Yeah, anyone who generates a new pluginreg.dat file while this bug is in the build will have a problem. Deleting your pluginreg.dat file is safe, just do that.
Comment 12 Ed Morley [:emorley] 2012-05-04 11:49:54 PDT
https://hg.mozilla.org/mozilla-central/rev/e53c3fb93f8b
Comment 13 Alice0775 White 2012-05-04 19:01:17 PDT
*** Bug 752128 has been marked as a duplicate of this bug. ***
Comment 14 CruNcher 2012-05-04 23:00:17 PDT
(In reply to Josh Aas (Mozilla Corporation) from comment #11)
> Yeah, anyone who generates a new pluginreg.dat file while this bug is in the
> build will have a problem. Deleting your pluginreg.dat file is safe, just do
> that.

Doesn't help me personaly a lot if i do that flash works fine indeed but after restart it fails again so i would have to delete now every time before i start firefox pluginreg.dat in my personal profile :)

though i wait for todays nightly to see if this is hopefully not the case anymore :)
Comment 15 Thomas Ahlblom 2012-05-06 02:30:17 PDT
*** Bug 752173 has been marked as a duplicate of this bug. ***
Comment 16 Josh Aas 2012-05-08 08:36:07 PDT
*** Bug 752338 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.