Last Comment Bug 751647 - speculative connect doesnt follow spdy ip pooling
: speculative connect doesnt follow spdy ip pooling
Status: RESOLVED FIXED
[spdy][http-conn]
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: 15 Branch
: x86_64 Linux
: -- minor (vote)
: mozilla15
Assigned To: Patrick McManus [:mcmanus]
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 11:20 PDT by Patrick McManus [:mcmanus]
Modified: 2012-06-21 06:41 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch 0 (1.19 KB, patch)
2012-05-03 11:24 PDT, Patrick McManus [:mcmanus]
honzab.moz: review+
Details | Diff | Splinter Review

Description Patrick McManus [:mcmanus] 2012-05-03 11:20:59 PDT
speculative http connections don't look up the spdy ip pooling table, so they connect to the unmapped host. This doesn't break anything because the main connection path does the right lookup, but it also isn't very useful :)
Comment 1 Patrick McManus [:mcmanus] 2012-05-03 11:24:51 PDT
Created attachment 620792 [details] [diff] [review]
patch 0
Comment 2 Honza Bambas (:mayhemer) 2012-05-07 06:05:15 PDT
Comment on attachment 620792 [details] [diff] [review]
patch 0

Review of attachment 620792 [details] [diff] [review]:
-----------------------------------------------------------------

::: netwerk/protocol/http/nsHttpConnectionMgr.cpp
@@ +2246,5 @@
>  
> +    // Check if there is a spdy ip pooling mapping for this host
> +    nsConnectionEntry *preferredEntry = GetSpdyPreferredEnt(ent);
> +    if (preferredEntry)
> +        ent = preferredEntry;

In other words: when you find a spdy preferred ent, it prevents creation of a new (unnecessary) connection for a host we may coalesce with an existing connection, right?  Could you please express this in some simple comment here?
Comment 3 Patrick McManus [:mcmanus] 2012-05-07 06:49:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/404b332f7664
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-05-07 17:54:27 PDT
http://hg.mozilla.org/mozilla-central/rev/404b332f7664

Note You need to log in before you can comment on or make changes to this bug.