Closed Bug 751658 Opened 8 years ago Closed 3 years ago

Crash/hang with SnowFX Java applet (which fails to load)

Categories

(Core :: Plug-ins, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX

People

(Reporter: stephend, Unassigned)

References

()

Details

(Keywords: hang, reproducible)

Crash Data

STR:

1. Load http://javaboutique.internet.com/Snow/ in a Firefox desktop nightly
2. Wait a while...

Expected Results:

Either the applet loads and initializes, or errors out gracefully (see below)

Actual Results:

We get the following:

load: class snowFX.class not found.
java.lang.ClassNotFoundException: snowFX.class
	at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
	at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Exception: java.lang.ClassNotFoundException: snowFX.class

...which in turns either/both hangs the browser, and then crashes the plugin, here:

https://crash-stats.mozilla.com/report/index/bp-cfb5f245-859a-42b8-ab14-062312120503 @ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_GetValue_NPPVpluginScriptableNPObject(mozilla::plugins::PPluginScriptableObjectParent**, short*)

https://crash-stats.mozilla.com/report/index/bp-82fc81d3-3fe5-4da6-b205-09f9b2120503 (@ hang | SleepStub)

See also bug 592894, which the 1st stack references; there hasn't been activity there in over a year, and it looks like we're waiting on comment from the Oracle folks; as the bug is still present, and 100% reproducible, we should seek some traction.

Kev/Tomcat: do we have a contact who can look into this?
See Also: → 592894
Version: unspecified → Trunk
Severity: major → critical
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_GetValue_NPPVpluginScriptableNPObject(mozilla::plugins::PPluginScriptableObjectParent**, short*)] [@ hang | SleepStub]
Keywords: hang, reproducible
Summary: Crash/hang with SnowFX Java applet (which fails to load) [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_GetValue_NPPVpluginScriptableNPObject(mozilla::plugins::PPluginScriptableObjectParent**, short*] → Crash/hang with SnowFX Java applet (which fails to load)
Crash Signature: [@ hang | mozilla::plugins::PPluginInstanceParent::CallNPP_GetValue_NPPVpluginScriptableNPObject(mozilla::plugins::PPluginScriptableObjectParent**, short*)] [@ hang | SleepStub] → [@ hang | SleepStub]
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.