Last Comment Bug 751668 - Avoid incorrectly using EXTEND_NONE
: Avoid incorrectly using EXTEND_NONE
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Jeff Muizelaar [:jrmuizel]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks: 750598
  Show dependency treegraph
 
Reported: 2012-05-03 12:12 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-05-08 07:57 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
beta+


Attachments
Avoid incorrectly using EXTEND_NONE (720 bytes, patch)
2012-05-03 12:12 PDT, Jeff Muizelaar [:jrmuizel]
joe: review+
jpr: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-05-03 12:12:58 PDT
Created attachment 620807 [details] [diff] [review]
Avoid incorrectly using EXTEND_NONE

It seems like we sometimes end up using EXTEND_NONE unintentionally, this is likely caused by different rounding between cairo and pixman. Pixman already does a similar reduction to EXTEND_NONE so there's not point in duplicating it here.
Comment 1 :Ehsan Akhgari 2012-05-03 13:05:50 PDT
Comment on attachment 620807 [details] [diff] [review]
Avoid incorrectly using EXTEND_NONE

Review of attachment 620807 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, I know nothing about this...
Comment 2 Joe Drew (not getting mail) 2012-05-03 13:23:43 PDT
Comment on attachment 620807 [details] [diff] [review]
Avoid incorrectly using EXTEND_NONE

This is totally safe, considering it's just an optimization, but it sure doesn't make me happy.

Don't forget to add it as a cairo patch.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-05-03 22:10:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f561a638fe1e
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-05-04 10:36:12 PDT
Comment on attachment 620807 [details] [diff] [review]
Avoid incorrectly using EXTEND_NONE

[Approval Request Comment]
Regression caused by (bug #): none
User impact if declined: black edges on images
Testing completed (on m-c, etc.): locally and on inbound
Risk to taking this patch (and alternatives if risky): Possible performance regression, but very unlikely. If there is a performance regression, it is likely to only effect mobile.
String changes made by this patch: none
Comment 5 Ed Morley [:emorley] 2012-05-04 11:41:03 PDT
https://hg.mozilla.org/mozilla-central/rev/f561a638fe1e
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-05-06 20:06:36 PDT
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> Comment on attachment 620807 [details] [diff] [review]
> Avoid incorrectly using EXTEND_NONE
> 
> [Approval Request Comment]
> Regression caused by (bug #): none
> User impact if declined: black edges on images
> Testing completed (on m-c, etc.): locally and on inbound
> Risk to taking this patch (and alternatives if risky): Possible performance
> regression, but very unlikely. If there is a performance regression, it is
> likely to only effect mobile.
> String changes made by this patch: none

let's let this bake on trunk for a couple nightlies
Comment 7 JP Rosevear [:jpr] 2012-05-07 08:01:07 PDT
Comment on attachment 620807 [details] [diff] [review]
Avoid incorrectly using EXTEND_NONE

Baked on on central, giving approval.
Comment 8 JP Rosevear [:jpr] 2012-05-07 08:01:40 PDT
Backfilling beta+ so its on our radar.
Comment 9 Jeff Muizelaar [:jrmuizel] 2012-05-07 14:25:42 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/e73465a6bfcb
Comment 10 JP Rosevear [:jpr] 2012-05-08 07:57:45 PDT
Aurora is actually 14.

Note You need to log in before you can comment on or make changes to this bug.