Implement a mechanism for a privileged domain ("app") to pre-cache files for manifest from another domain ("app")

RESOLVED DUPLICATE of bug 702369

Status

()

defect
RESOLVED DUPLICATE of bug 702369
7 years ago
6 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The use case here is an "app store" on device: when the user installs an app, they usually want the files to be downloaded and cached immediately, not upon the first load of the app.  So we want to allow the app manager to kick off a download for an app that's not loaded.  We also want the app manager to be notified of failure to download and cache files, so that it can retry.

We'll need new API for this.  I think something very simple on mozApps might make sense.  Fabrice, any suggestions?

This may or may not be related to bug 702369, not sure.
The OWA needs this too... On desktop this means launching another process and some other unpleasant stuff, so maybe we need to coordinate?
That looks like a dupe to me. 

We can trigger the download automatically when we find the appropriate entry in the webapp manifest.

We can track also the download status (scheduleUpdate() gives us a nsIOfflineCacheUpdate on which we can attach an observer).

For apps that specify their appcache manifest, maybe we could expose the on the DOM application object the applicationCache so the UI could track download status (and hide apps that have not finished to download) ?
(In reply to ben turner [:bent] from comment #1)
> The OWA needs this too... On desktop this means launching another process
> and some other unpleasant stuff, so maybe we need to coordinate?

I don't understand what this means.  OWA is using appcache right?
I think this is basically part of the install() function in the OWA API. I don't think we need anything beyond that. Feel free to reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702369
No longer blocks: b2g-app-updates
You need to log in before you can comment on or make changes to this bug.