Drag and drop not working in XHTML as application/xhtml+xml

REOPENED
Unassigned

Status

()

Core
General
REOPENED
5 years ago
a month ago

People

(Reporter: John A. Bilicki III, Unassigned)

Tracking

({regression, xhtml})

Trunk
x86_64
All
regression, xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 620902 [details]
gecko_dad.xhtml

User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:10.0.4) Gecko/20100101 Firefox/10.0.4
Build ID: 20120420145309

Steps to reproduce:

Created a drag and drop example application.


Actual results:

The attached files demonstrate that using the exact same code that drag and drop is not working when the mime is application/xhtml+xml. When the file is renamed .html to generate a text/html mime the drag and drop functionality works.


Expected results:

The drag and drop functionality should work regardless of the mime/media type.
(Reporter)

Comment 1

5 years ago
Created attachment 620904 [details]
The text/html version of the test case.

The first attachment is application/xhtml+xml (did not see an option to set it as so), this is text/html. The text/html copy works, the application/xhtml+xml does not.

Simple directions: click and drag the image up in to the blue division element.

Updated

5 years ago
Keywords: xhtml

Comment 2

5 years ago
Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/714faf8ec149
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100524 Minefield/3.7a5pre ID:20100524162132
Fails:
http://hg.mozilla.org/mozilla-central/rev/2e4105f85be9
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100524 Minefield/3.7a5pre ID:20100524172122
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=714faf8ec149&tochange=2e4105f85be9
Triggered by:
0c440c656ada	Mats Palmgren — Bug 39098 - Elements with visibility:hidden, visibility:collapse, or display:none get copied to the clipboard. r=dbaron
Blocks: 39098
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows Server 2003 → All
Version: 14 Branch → Trunk

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703514
(Reporter)

Comment 4

2 years ago
Created attachment 8638955 [details]
video.xhtml

This bug is NOT the same bug with bookmarks and continues to persist. This bug should be easy to fix if it's just an array mime list, just add the application/xhtml+xml back to the list.

If you rename this "video.xhtml" attachment to "video.html" and render it as text/html then drag-and-drop works perfectly fine.
(Reporter)

Updated

a month ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #620902 - Attachment mime type: application/octet-stream → application/xhtml+xml
Attachment #620904 - Attachment mime type: text/plain → text/html
You need to log in before you can comment on or make changes to this bug.