Last Comment Bug 751778 - Drag and drop not working in XHTML as application/xhtml+xml
: Drag and drop not working in XHTML as application/xhtml+xml
Status: RESOLVED DUPLICATE of bug 703514
: regression, xhtml
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86_64 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 39098
  Show dependency treegraph
 
Reported: 2012-05-03 17:10 PDT by John A. Bilicki III
Modified: 2015-07-25 14:12 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
gecko_dad.xhtml (1.01 KB, application/octet-stream)
2012-05-03 17:10 PDT, John A. Bilicki III
no flags Details
The text/html version of the test case. (1.01 KB, text/plain)
2012-05-03 17:12 PDT, John A. Bilicki III
no flags Details
video.xhtml (567 bytes, application/xhtml+xml)
2015-07-25 14:12 PDT, John A. Bilicki III
no flags Details

Description John A. Bilicki III 2012-05-03 17:10:37 PDT
Created attachment 620902 [details]
gecko_dad.xhtml

User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:10.0.4) Gecko/20100101 Firefox/10.0.4
Build ID: 20120420145309

Steps to reproduce:

Created a drag and drop example application.


Actual results:

The attached files demonstrate that using the exact same code that drag and drop is not working when the mime is application/xhtml+xml. When the file is renamed .html to generate a text/html mime the drag and drop functionality works.


Expected results:

The drag and drop functionality should work regardless of the mime/media type.
Comment 1 John A. Bilicki III 2012-05-03 17:12:23 PDT
Created attachment 620904 [details]
The text/html version of the test case.

The first attachment is application/xhtml+xml (did not see an option to set it as so), this is text/html. The text/html copy works, the application/xhtml+xml does not.

Simple directions: click and drag the image up in to the blue division element.
Comment 2 Alice0775 White 2012-05-03 21:33:40 PDT
Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/714faf8ec149
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100524 Minefield/3.7a5pre ID:20100524162132
Fails:
http://hg.mozilla.org/mozilla-central/rev/2e4105f85be9
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100524 Minefield/3.7a5pre ID:20100524172122
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=714faf8ec149&tochange=2e4105f85be9
Triggered by:
0c440c656ada	Mats Palmgren — Bug 39098 - Elements with visibility:hidden, visibility:collapse, or display:none get copied to the clipboard. r=dbaron
Comment 3 Mats Palmgren (:mats) 2012-05-04 04:11:57 PDT

*** This bug has been marked as a duplicate of bug 703514 ***
Comment 4 John A. Bilicki III 2015-07-25 14:12:14 PDT
Created attachment 8638955 [details]
video.xhtml

This bug is NOT the same bug with bookmarks and continues to persist. This bug should be easy to fix if it's just an array mime list, just add the application/xhtml+xml back to the list.

If you rename this "video.xhtml" attachment to "video.html" and render it as text/html then drag-and-drop works perfectly fine.

Note You need to log in before you can comment on or make changes to this bug.