Note: There are a few cases of duplicates in user autocompletion which are being worked on.

crash printing due to font inflation

RESOLVED FIXED in Firefox 14

Status

()

Core
Layout
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({crash})

Trunk
mozilla15
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox14 fixed, blocking-fennec1.0 +)

Details

(Whiteboard: [readability])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Created attachment 620934 [details] [diff] [review]
patch

I hit a crash printing in a debug build due to font inflation code.  This crash would also affect builds with font inflation enabled and affect other sorts of pagination (e.g., multicol).  (There's some font inflation code that I intentionally run in debug builds even when font inflation is disabled, so that we see the assertions.)

In any case, this patch fixes it; it's one place I missed maintaining the invariant that this function operates only on first-in-flows.
Attachment #620934 - Flags: review?(roc)
Attachment #620934 - Flags: review?(roc) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d81667d36dd
Target Milestone: --- → mozilla15

Updated

5 years ago
Blocks: 750202
Severity: normal → critical
(Assignee)

Comment 2

5 years ago
Created attachment 621050 [details] [diff] [review]
patch 2

Crashed again; turns out I missed another one.  Hopefully this is really the last one, though.
Attachment #621050 - Flags: review?(roc)

Comment 3

5 years ago
(In reply to David Baron [:dbaron] from comment #1)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/4d81667d36dd

https://hg.mozilla.org/mozilla-central/rev/4d81667d36dd
Attachment #621050 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/33168c4c4703
https://hg.mozilla.org/mozilla-central/rev/33168c4c4703
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
Comment on attachment 620934 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 706193
User impact if declined: crash
Testing completed (on m-c, etc.): on mozilla-central for a bit
Risk to taking this patch (and alternatives if risky): very low
String changes made by this patch: none
Attachment #620934 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

5 years ago
Comment on attachment 621050 [details] [diff] [review]
patch 2

[Approval Request Comment]
Regression caused by (bug #): bug 706193
User impact if declined: crash
Testing completed (on m-c, etc.): on mozilla-central for a bit
Risk to taking this patch (and alternatives if risky): very low
String changes made by this patch: none
Attachment #621050 - Flags: approval-mozilla-aurora?

Updated

5 years ago
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → +
Attachment #620934 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #621050 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/3421c2085f49
https://hg.mozilla.org/releases/mozilla-aurora/rev/65bf57670069
status-firefox14: --- → fixed
You need to log in before you can comment on or make changes to this bug.