BasicTiledThebesLayer should use OPERATOR_SOURCE

RESOLVED FIXED in Firefox 14

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

unspecified
mozilla14
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed, blocking-fennec1.0 +)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 621055 [details] [diff] [review]
patch
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #621055 - Flags: review?(jmuizelaar)
(Assignee)

Comment 2

5 years ago
Low risk perf win, suggesting tracking+uplift.
tracking-fennec: --- → ?
Attachment #621055 - Flags: review?(jmuizelaar) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c41d847fb36e
(Assignee)

Comment 4

5 years ago
Comment on attachment 621055 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): Not a regression
User impact if declined: Useless fill affecting peformance
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): very small
String changes made by this patch: none
Attachment #621055 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/c41d847fb36e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15

Updated

5 years ago
blocking-fennec1.0: --- → ?
(In reply to Benoit Girard (:BenWa) from comment #4)
> Comment on attachment 621055 [details] [diff] [review]
> patch
> 
> [Approval Request Comment]
> Regression caused by (bug #): Not a regression
> User impact if declined: Useless fill affecting peformance
> Testing completed (on m-c, etc.): landed on m-c
> Risk to taking this patch (and alternatives if risky): very small
> String changes made by this patch: none

let's let this bake on trunk for a couple nightlies before uplifting

Comment 7

5 years ago
We are leaving all non-beta+ bugs nominated for Aurora approval in the queue until FN14 Beta 1 is signed off on by QA.

Comment 8

5 years ago
Comment on attachment 621055 [details] [diff] [review]
patch

[Triage Comment]
Broken WebGL apps, and we're very early in the cycle. Approving for Aurora 14.
Attachment #621055 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-fennec: ? → ---
blocking-fennec1.0: ? → +
Benoit, can you land this on Aurora?
(Assignee)

Comment 10

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> Comment on attachment 621055 [details] [diff] [review]
> patch
> 
> [Triage Comment]
> Broken WebGL apps, and we're very early in the cycle. Approving for Aurora
> 14.

This wont impact WebGL. This just give us a bit better performance.

(In reply to Joe Drew (:JOEDREW!) from comment #9)
> Benoit, can you land this on Aurora?

landing now
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e381efd3d9c5
status-firefox14: --- → fixed
status-firefox15: --- → fixed
Target Milestone: mozilla15 → mozilla14

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.