Last Comment Bug 752031 - Librarify the jsrefest suite
: Librarify the jsrefest suite
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks: 745230
  Show dependency treegraph
 
Reported: 2012-05-04 13:51 PDT by Terrence Cole [:terrence]
Modified: 2012-05-11 11:41 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (3.20 KB, patch)
2012-05-04 13:51 PDT, Terrence Cole [:terrence]
dmandelin: review+
Details | Diff | Review

Description Terrence Cole [:terrence] 2012-05-04 13:51:06 PDT
Created attachment 621161 [details] [diff] [review]
v0

Put all the random .py files in tests into a lib dir.  Totally trivial.
Comment 1 David Mandelin [:dmandelin] 2012-05-04 16:44:05 PDT
Comment on attachment 621161 [details] [diff] [review]
v0

Review of attachment 621161 [details] [diff] [review]:
-----------------------------------------------------------------

Missing the moved files?
Comment 2 Terrence Cole [:terrence] 2012-05-07 09:53:35 PDT
Wow, that's odd.  The "Details" link shows:

diff --git a/js/src/tests/lib/__init__.py b/js/src/tests/lib/__init__.py
new file mode 100644
diff --git a/js/src/tests/manifest.py b/js/src/tests/lib/manifest.py
rename from js/src/tests/manifest.py
rename to js/src/tests/lib/manifest.py
diff --git a/js/src/tests/progressbar.py b/js/src/tests/lib/progressbar.py
rename from js/src/tests/progressbar.py
rename to js/src/tests/lib/progressbar.py
diff --git a/js/src/tests/results.py b/js/src/tests/lib/results.py
rename from js/src/tests/results.py
rename to js/src/tests/lib/results.py
diff --git a/js/src/tests/tasks_unix.py b/js/src/tests/lib/tasks_unix.py
rename from js/src/tests/tasks_unix.py
rename to js/src/tests/lib/tasks_unix.py
diff --git a/js/src/tests/tasks_win.py b/js/src/tests/lib/tasks_win.py
rename from js/src/tests/tasks_win.py
rename to js/src/tests/lib/tasks_win.py
diff --git a/js/src/tests/tests.py b/js/src/tests/lib/tests.py
rename from js/src/tests/tests.py
rename to js/src/tests/lib/tests.py

at the bottom, but the Diff and Splinter Review links don't mention these files at all.
Comment 3 David Mandelin [:dmandelin] 2012-05-07 12:59:18 PDT
Comment on attachment 621161 [details] [diff] [review]
v0

Oh, OK, it looks like Splinter wasn't smart enough to pick up the moves.
Comment 4 Terrence Cole [:terrence] 2012-05-10 17:13:51 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e821143ee3e
Comment 5 Matt Brubeck (:mbrubeck) 2012-05-11 11:41:18 PDT
https://hg.mozilla.org/mozilla-central/rev/6e821143ee3e

Note You need to log in before you can comment on or make changes to this bug.