If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Check to see if your plugins are up to date" sends me to invalid URL

RESOLVED DUPLICATE of bug 752161

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 752161
6 years ago
6 years ago

People

(Reporter: Paul, Unassigned)

Tracking

11 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Click "Check to see if your plugins are up to date" in Add-ons Manager Plugins page.


Actual results:

Sent to invalid URL:

https://www.mozilla.com/en/404


Expected results:

Should have been sent to:

https://www.mozilla.org/en-US/plugincheck/
I confirm this bug and it is still present in Firefox 12.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0

This bug affects all operating systems. It happens on Windows / Linux / Mac.

Comment 3

6 years ago
I have this same issue with: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20120504 Firefox/14.0a2

Comment 4

6 years ago
Have same problem with FF 12. Gone to about:config and looked at:

plugins.update.url;https://www.mozilla.com/%LOCALE%/plugincheck/

however, i am redirected to the 404. typing this address manually takes me to the proper site for both Http and Https.
So question is: how is link not "reading" about:config string for this url?
(I know, I am just humanizing computer behavior lol)

Keep up the good work!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752161
(Reporter)

Comment 6

6 years ago
Bug reporting has always seemed a curious thing to me.  For example, this bug, 752073, is a 'duplicate' of of bug 752161, yet it seems the other way around to me.
The reason why I duped this report to bug 752161 is that:
- This one if reported to the product Firefox and that is wrong. There is nothing wrong with the source Firefox source code but it's instead a bug with the website.
bug 752161 is already in the right product

- bug 752161 is already confirmed
- bug 752161 contains the right analysis of the issue (https redirect issue)
- there is already a bug duped to bug 752161 and it's in most cases better to collect the dupes in one single bug.

Anyway, thanks for the bug report !
You need to log in before you can comment on or make changes to this bug.