Last Comment Bug 752092 - Support building SpiderMonkey without JS_HAS_XML_SUPPORT
: Support building SpiderMonkey without JS_HAS_XML_SUPPORT
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: mozilla15
Assigned To: Jason Orendorff [:jorendorff]
:
:
Mentors:
Depends on:
Blocks: 752632
  Show dependency treegraph
 
Reported: 2012-05-04 15:57 PDT by Jason Orendorff [:jorendorff]
Modified: 2012-05-16 19:49 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (29.76 KB, patch)
2012-05-04 15:58 PDT, Jason Orendorff [:jorendorff]
terrence.d.cole: review+
Details | Diff | Splinter Review

Description Jason Orendorff [:jorendorff] 2012-05-04 15:57:16 PDT
This is something Terrence needs for GC work, and it'll help us remove XML support eventually.
Comment 1 Jason Orendorff [:jorendorff] 2012-05-04 15:58:57 PDT
Created attachment 621208 [details] [diff] [review]
v1

This leaves JS_HAS_XML_SUPPORT defined for now, but rearranges the #ifdefs so that it'll compile if you manually hack jsversion.h and turn it off.

Terrence told me he's working on a patch for this too. I trust his patch more since he's actually going to be building with E4X support off, probably for months.
Comment 2 Terrence Cole [:terrence] 2012-05-04 16:24:23 PDT
Comment on attachment 621208 [details] [diff] [review]
v1

Review of attachment 621208 [details] [diff] [review]:
-----------------------------------------------------------------

This all looks perfectly straightforward.  I don't think we have to wait for getting the tests to work before committing this since it still defaults to off.

Also, double plus bonus points if you add --disable-e4x to configure -- it should be easy as easy as copying the block for --disable-incremental and updating the variable names.
Comment 3 Jason Orendorff [:jorendorff] 2012-05-16 07:50:02 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8be72d70f108
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-05-16 19:49:37 PDT
https://hg.mozilla.org/mozilla-central/rev/8be72d70f108

Note You need to log in before you can comment on or make changes to this bug.