Closed Bug 752112 Opened 10 years ago Closed 10 years ago

Test failures from Jetpack suite aren't parsed

Categories

(Tree Management Graveyard :: TBPL, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mah, Assigned: mah)

References

Details

Attachments

(1 file, 1 obsolete file)

Since test failures from addons don't show up in tinderbox, code that breaks jetpack gets committed without anyone fixing it.

Because the addons-sdk team wants to keep dependencies to a minimum, only python's unittest is used. tldp should be extended as necessary to parse the test code output by jetpack.

It looks like this will mean adding a LineFilter implementation for the test output.
Thanks for offering to take this on!
Assignee: nobody → mah
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Hrm, those test suites are just hidden AFAIK (see https://tbpl.mozilla.org/?noignore=1) since they've been perma-orange, so looking at them doesn't really make much sense.  Am I missing what this bug is about?
Yeah, he means that we need an errorparser that recognizes the jetpack suite's way of marking test failures ("^error: TEST FAILED" at least, possibly more), since it doesn't do TEST-UNEXPECTED-FAIL.
Summary: Tests from addons-sdk don't show up in tinderbox → Test failures from Jetpack suite aren't parsed
Here is a minimal patch that got it to work for me.
It took me a while to figure out what was going on.  Part of the problem was the hidden errors (the '@' prefix)

When I removed those, I saw the following:

  PHP Warning:  ftp_fget(): Illegal PORT command (Stingray Traffic Manager FTP
  proxy). in ..../php/inc/RawGzLogDownloader.php on line 29,

I don't know how much large the files that RawGzLogDownloader usually gets are, but so far it works for a test box.
Attachment #621358 - Flags: review+
Comment on attachment 621360 [details] [diff] [review]
Patch so log fetching would work on my virtual machine

Review of attachment 621360 [details] [diff] [review]:
-----------------------------------------------------------------

::: php/inc/RawGzLogDownloader.php
@@ -26,5 @@
> -    if (!@ftp_login($ftpstream, "anonymous", ""))
> -      throw new Exception("Couldn't connect to Mozilla FTP server.");
> -    $fp = tmpfile();
> -    if (!@ftp_fget($ftpstream, $fp, $path, FTP_BINARY))
> -      throw new Exception("Log not available at URL {$this->logURL}.");

Just wondering what kind of error handling the new code has. What happens to file_get_contents when the url is a 404?
Comment on attachment 621360 [details] [diff] [review]
Patch so log fetching would work on my virtual machine

moving fixed patch to Bug 754420
Attachment #621360 - Attachment is obsolete: true
http://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/rev/d36a2aea379f (probably be deployed to tbpl.m.o early next week)
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Depends on: 756723
Depends on: 756959
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.