Port |Bug 641892 - Support showing multiple popup notification icons at the same time| to SeaMonkey

VERIFIED FIXED in Firefox 15

Status

SeaMonkey
UI Design
P2
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.12
Dependency tree / graph
Bug Flags:
in-testsuite +

SeaMonkey Tracking Flags

(firefox15 fixed, seamonkey2.10 verified, seamonkey2.11 verified)

Details

([fixed in SM 2.10: Cv2, Dv1a, Ev1; SM 2.11: Hv1; SM 2.12: Av1, Bv1-FF, Fv1, Gv1-FF] [perma-orange], URL)

Attachments

(7 attachments, 1 obsolete attachment)

1.38 KB, patch
neil@parkwaycc.co.uk
: review+
sgautherie
: feedback+
Details | Diff | Splinter Review
6.04 KB, patch
Gavin
: review+
Details | Diff | Splinter Review
5.49 KB, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
2.05 KB, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
3.84 KB, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
2.74 KB, patch
Gavin
: review+
Details | Diff | Splinter Review
1.86 KB, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js | main action #1 was clicked
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js | only one notification displayed - Got 3, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js | only one notification displayed - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js | message matches - Got This is popup notification test-notification-7 from test 7 1, expected This is popup notification test-notification-6 from test 6
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js | id matches - Got test-notification-7-notification, expected test-notification-6-notification
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js | Test timed out

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_dragdrop.js | an unexpected uncaught JS exception reported through window.onerror - ReferenceError: info is not defined at chrome://mochitests/content/browser/suite/browser/test/browser_popupNotification.js:96
[And a lot more of these: bustage after timeout.]
}

*****

Neil (or anyone else), could you do this one?
(Wrt css...)
Created attachment 621296 [details] [diff] [review]
(Av1) Update notification-anchor-icon rules in navigator.css
[Checked in: Comment 4]

I seem that failing tests is caused by no reflected CSS changed in Bug 641892.
This patch may pass tests but I have not adjusted styles (in Bug 641892, I adjusted the margin of anchor icons).
(Assignee)

Comment 2

5 years ago
Comment on attachment 621296 [details] [diff] [review]
(Av1) Update notification-anchor-icon rules in navigator.css
[Checked in: Comment 4]

I confirm this minimal port fixes the existing test ;-)

I'll update the test in a separate patch.
Can you check/deal with the theme updates?
Attachment #621296 - Flags: review?(neil)
Attachment #621296 - Flags: feedback+

Comment 3

5 years ago
Comment on attachment 621296 [details] [diff] [review]
(Av1) Update notification-anchor-icon rules in navigator.css
[Checked in: Comment 4]

I'm not actually sure that I like Firefox's theme changes, so don't bother.
Attachment #621296 - Flags: review?(neil) → review+
(Assignee)

Comment 4

5 years ago
Comment on attachment 621296 [details] [diff] [review]
(Av1) Update notification-anchor-icon rules in navigator.css
[Checked in: Comment 4]

http://hg.mozilla.org/comm-central/rev/1b5307fe831b

***

See
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
for future patches ;-)
Attachment #621296 - Attachment description: patch? → (Av1) Update notification-anchor-icon rules in navigator.css
Attachment #621296 - Attachment filename: diff → 752216-Av1_navigator-css.diff
(Assignee)

Updated

5 years ago
Attachment #621296 - Attachment description: (Av1) Update notification-anchor-icon rules in navigator.css → (Av1) Update notification-anchor-icon rules in navigator.css [Checked in: Comment 4]
(Assignee)

Comment 5

5 years ago
Created attachment 621410 [details] [diff] [review]
(Bv1-FF) browser_popupNotification.js: Fix nits
[Checked in: Comment 15]

Back-port from SeaMonkey.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #621410 - Flags: review?(gavin.sharp)
(Assignee)

Comment 6

5 years ago
Created attachment 621411 [details] [diff] [review]
(Cv1) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|

The feature was ported in bug 595810 part 10.
The test was explicitly not included in bug 595810 test update.
I am simply adding it with a s/is/todo_is/ and a comment, fwiw.
Attachment #621411 - Flags: review?(neil)
(Assignee)

Comment 7

5 years ago
Created attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

Trivial copy.
Attachment #621412 - Flags: review?(neil)
(Assignee)

Comment 8

5 years ago
Created attachment 621413 [details] [diff] [review]
(Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml|
[Checked in: Comments 26, 32, 36]

Trivial copy.
Attachment #621413 - Flags: review?(neil)
(Assignee)

Comment 9

5 years ago
Created attachment 621414 [details] [diff] [review]
(Fv1) browser_popupNotification.js: Port |Bug 641892 - Support showing multiple popup notification icons at the same time|
[Checked in: Comment 27]

Trivial copy (with 2 ',' nits).
Attachment #621414 - Flags: review?(neil)
(Assignee)

Updated

5 years ago
Depends on: 670851, 587587, 617553, 595810
Comment on attachment 621411 [details] [diff] [review]
(Cv1) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|

So you didn't want to try to simulate chromeless mode within the test?

>+      loadURI("about:addons", function() {
Is there any point in loading about:addons?
Comment on attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

>   // Test notification when chrome is hidden
>-  { // Test #18
>+  { // Test #19
???

Updated

5 years ago
Attachment #621413 - Flags: review?(neil) → review+

Updated

5 years ago
Attachment #621414 - Flags: review?(neil) → review+
(Assignee)

Comment 12

5 years ago
(In reply to neil@parkwaycc.co.uk from comment #10)

> So you didn't want to try to simulate chromeless mode within the test?

I read you suggested that, but my point wrt this bug is only to resync' the test.

If you want that, I suggest you file a follow-up bug to add a "SeaMonkey 19bis" test, or to rewrite the "Firefox 19" test in a way that would work on both applications.
(At least, there will be a todo ftb :-|)
In this case, I thought we should either fix the application or let the test be.

> >+      loadURI("about:addons", function() {
> Is there any point in loading about:addons?

I don't know: the test pass and is documented. That's all I care about ftb.


(In reply to neil@parkwaycc.co.uk from comment #11)
> >-  { // Test #18
> >+  { // Test #19
> ???

Patch Cv1 adds a second "18", which is renamed in patch Dv1:
I preferred to do these ports exactly as they happened in Firefox.
(In reply to Serge Gautherie from comment #12)
> (In reply to comment #10)
> > So you didn't want to try to simulate chromeless mode within the test?
> I read you suggested that, but my point wrt this bug is only to resync' the
> test.
> 
> If you want that, I suggest you file a follow-up bug to add a "SeaMonkey
> 19bis" test, or to rewrite the "Firefox 19" test in a way that would work on
> both applications.
This works on SeaMonkey, but I have no idea whether it will work on Firefox:
  { // Test #19
    run: function () {
      window.locationbar.visible = false;
      this.notifyObj = new basicNotification();
      this.notification = showNotification(this.notifyObj);
      window.locationbar.visible = true;
    },

> (In reply to comment #11)
> > >-  { // Test #18
> > >+  { // Test #19
> > ???
> Patch Cv1 adds a second "18", which is renamed in patch Dv1:
> I preferred to do these ports exactly as they happened in Firefox.
Well I really don't see the point of that, I want the 19th test to be numbered 19 when it lands please!

Updated

5 years ago
Attachment #621411 - Flags: review?(neil) → review-
Comment on attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

r=me except as per comment #11.
Attachment #621412 - Flags: review?(neil) → review+
Attachment #621410 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 15

5 years ago
Comment on attachment 621410 [details] [diff] [review]
(Bv1-FF) browser_popupNotification.js: Fix nits
[Checked in: Comment 15]

https://hg.mozilla.org/mozilla-central/rev/835d5fab89dc
Attachment #621410 - Attachment description: (Bv1-FF) browser_popupNotification.js: Fix nits → (Bv1-FF) browser_popupNotification.js: Fix nits [Checked in: Comment 15]
(Assignee)

Comment 16

5 years ago
Created attachment 621578 [details] [diff] [review]
(Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19
[Checked in: Comment 21]

Per comment 13.
Attachment #621578 - Flags: review?(gavin.sharp)
Attachment #621578 - Flags: feedback?(neil)
Comment on attachment 621578 [details] [diff] [review]
(Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19
[Checked in: Comment 21]

Not quite sure what the point is since all the new code is mine anyway...
Attachment #621578 - Flags: feedback?(neil)
(Assignee)

Comment 18

5 years ago
Comment on attachment 621578 [details] [diff] [review]
(Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19
[Checked in: Comment 21]

Succeeded as
https://tbpl.mozilla.org/?tree=Try&rev=8a9296e48cdc
Does the test still fail if you break the relevant functionality?
(Assignee)

Comment 20

5 years ago
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #19)
> Does the test still fail if you break the relevant functionality?

I tested that the check fails if I comment out the "visible = false" line.
Attachment #621578 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 21

5 years ago
Comment on attachment 621578 [details] [diff] [review]
(Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19
[Checked in: Comment 21]

https://hg.mozilla.org/mozilla-central/rev/cb6759edb577
Attachment #621578 - Attachment description: (Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19 → (Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19 [Checked in: Comment 20]
(Assignee)

Updated

5 years ago
Attachment #621578 - Attachment description: (Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19 [Checked in: Comment 20] → (Gv1-FF) browser_popupNotification.js: Use locationbar to simplify test 19 [Checked in: Comment 21]
(Assignee)

Comment 22

5 years ago
Created attachment 622585 [details] [diff] [review]
(Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF
[Checked in: See comments 23+28, 30, 34(*2)]

Cv1, with comment 13 suggestion(s).
Attachment #621411 - Attachment is obsolete: true
Attachment #622585 - Flags: review?(neil)
(Assignee)

Updated

5 years ago
status-firefox15: --- → fixed

Updated

5 years ago
Attachment #622585 - Flags: review?(neil) → review+
(Assignee)

Comment 23

5 years ago
Comment on attachment 622585 [details] [diff] [review]
(Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF
[Checked in: See comments 23+28, 30, 34(*2)]

http://hg.mozilla.org/comm-central/rev/89683cf236ec


[Approval Request Comment]
No risk, test-only.
Attachment #622585 - Attachment description: (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF → (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: Comment 23]
Attachment #622585 - Flags: approval-comm-beta?
Attachment #622585 - Flags: approval-comm-aurora?
(Assignee)

Comment 24

5 years ago
Comment on attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

http://hg.mozilla.org/comm-central/rev/fea194b18caa


[Approval Request Comment]
No risk, test-only.
Attachment #621412 - Attachment description: (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| → (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: Comment 24]
Attachment #621412 - Flags: approval-comm-beta?
Attachment #621412 - Flags: approval-comm-aurora?
(Assignee)

Comment 25

5 years ago
Comment on attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

(In reply to Serge Gautherie (:sgautherie) from comment #24)
> http://hg.mozilla.org/comm-central/rev/fea194b18caa

Dv1, with comment 13 suggestion(s).
Attachment #621412 - Attachment description: (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: Comment 24] → (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: See comment 24]
(Assignee)

Comment 26

5 years ago
Comment on attachment 621413 [details] [diff] [review]
(Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml|
[Checked in: Comments 26, 32, 36]

http://hg.mozilla.org/comm-central/rev/5fdf33810460

[Approval Request Comment]
No risk, test-only.
Attachment #621413 - Attachment description: (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| → (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comment 25]
Attachment #621413 - Flags: approval-comm-beta?
Attachment #621413 - Flags: approval-comm-aurora?
(Assignee)

Comment 27

5 years ago
Comment on attachment 621414 [details] [diff] [review]
(Fv1) browser_popupNotification.js: Port |Bug 641892 - Support showing multiple popup notification icons at the same time|
[Checked in: Comment 27]

http://hg.mozilla.org/comm-central/rev/7715bb3d4e2d

[Approval Request Comment]
No risk, test-only.
Attachment #621414 - Attachment description: (Fv1) browser_popupNotification.js: Port |Bug 641892 - Support showing multiple popup notification icons at the same time| → (Fv1) browser_popupNotification.js: Port |Bug 641892 - Support showing multiple popup notification icons at the same time| [Checked in: Comment 26]
(Assignee)

Updated

5 years ago
Attachment #621414 - Attachment description: (Fv1) browser_popupNotification.js: Port |Bug 641892 - Support showing multiple popup notification icons at the same time| [Checked in: Comment 26] → (Fv1) browser_popupNotification.js: Port |Bug 641892 - Support showing multiple popup notification icons at the same time| [Checked in: Comment 27]
(Assignee)

Updated

5 years ago
Attachment #621413 - Attachment description: (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comment 25] → (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comment 26]
(Assignee)

Comment 28

5 years ago
Comment on attachment 622585 [details] [diff] [review]
(Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF
[Checked in: See comments 23+28, 30, 34(*2)]

http://hg.mozilla.org/comm-central/rev/fa888360b067
(Hv1) browser_popupNotification.js: Copy missed nit from patch Gv1-FF
Attachment #622585 - Attachment description: (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: Comment 23] → (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comment 23+28]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Keywords: regression
Resolution: --- → FIXED
(Assignee)

Comment 29

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1337348393.1337352489.23433.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/05/18 06:39:53

V.Fixed
Status: RESOLVED → VERIFIED

Updated

5 years ago
Attachment #622585 - Flags: approval-comm-beta?
Attachment #622585 - Flags: approval-comm-beta+
Attachment #622585 - Flags: approval-comm-aurora?
Attachment #622585 - Flags: approval-comm-aurora+

Updated

5 years ago
Attachment #621412 - Flags: approval-comm-beta?
Attachment #621412 - Flags: approval-comm-beta+
Attachment #621412 - Flags: approval-comm-aurora?
Attachment #621412 - Flags: approval-comm-aurora+

Updated

5 years ago
Attachment #621413 - Flags: approval-comm-beta?
Attachment #621413 - Flags: approval-comm-beta+
Attachment #621413 - Flags: approval-comm-aurora?
Attachment #621413 - Flags: approval-comm-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [perma-orange] → [c-n: 89683cf236ec + fa888360b067, fea194b18caa, 5fdf33810460 to c-a and c-b] [perma-orange]
(Assignee)

Comment 30

5 years ago
Comment on attachment 622585 [details] [diff] [review]
(Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF
[Checked in: See comments 23+28, 30, 34(*2)]

http://hg.mozilla.org/releases/comm-beta/rev/cb351f3a6c59
Attachment #622585 - Attachment description: (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comment 23+28] → (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comment 23+28 & 30]
(Assignee)

Comment 31

5 years ago
Comment on attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

http://hg.mozilla.org/releases/comm-beta/rev/71e5441743eb
Attachment #621412 - Attachment description: (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: See comment 24] → (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: See comment 24 & 31]
(Assignee)

Comment 32

5 years ago
Comment on attachment 621413 [details] [diff] [review]
(Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml|
[Checked in: Comments 26, 32, 36]

http://hg.mozilla.org/releases/comm-beta/rev/6024971673a8
Attachment #621413 - Attachment description: (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comment 26] → (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comment 26 & 32]
(Assignee)

Comment 33

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Beta/1337595251.1337600055.1708.gz
WINNT 5.2 comm-beta debug test mochitest-other on 2012/05/21 03:14:11

seamonkey2.10: verified.
status-seamonkey2.10: --- → verified
status-seamonkey2.11: --- → affected
Whiteboard: [c-n: 89683cf236ec + fa888360b067, fea194b18caa, 5fdf33810460 to c-a and c-b] [perma-orange] → [c-n: 89683cf236ec + fa888360b067, fea194b18caa, 5fdf33810460 to c-a] [perma-orange]
(Assignee)

Updated

5 years ago
tracking-seamonkey2.11: --- → ?
Comment on attachment 622585 [details] [diff] [review]
(Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF
[Checked in: See comments 23+28, 30, 34(*2)]

http://hg.mozilla.org/releases/comm-aurora/rev/3a6c8ae58492
http://hg.mozilla.org/releases/comm-aurora/rev/b091e8c8bda2
Attachment #622585 - Attachment description: (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comment 23+28 & 30] → (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comments 23+28, 30, 34]
Comment on attachment 621412 [details] [diff] [review]
(Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()|
[Checked in: See comments 24, 31, 35]

http://hg.mozilla.org/releases/comm-aurora/rev/b1c25eeb11dd
Attachment #621412 - Attachment description: (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: See comment 24 & 31] → (Dv1) Port |Bug 587587 - Always dismiss popup notifications when they are hidden, and add "removeOnDismissal" option to show()| [Checked in: See comments 24, 31, 35]
Comment on attachment 621413 [details] [diff] [review]
(Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml|
[Checked in: Comments 26, 32, 36]

http://hg.mozilla.org/releases/comm-aurora/rev/d869f61c3d6a
Attachment #621413 - Attachment description: (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comment 26 & 32] → (Ev1) Port |Bug 670851 - browser_bug519216.js, browser_popupNotification.js and browser_library_middleclick.js cause exception in tabbrowser.xml| [Checked in: Comments 26, 32, 36]
Keywords: checkin-needed
Whiteboard: [c-n: 89683cf236ec + fa888360b067, fea194b18caa, 5fdf33810460 to c-a] [perma-orange] → [perma-orange]
(Assignee)

Updated

5 years ago
status-seamonkey2.11: affected → fixed
tracking-seamonkey2.11: ? → ---
Whiteboard: [perma-orange] → [fixed in SM 2.10: Cv2, Dv1a, Ev1; SM 2.12: Av1, Bv1-FF, Fv1, Gv1-FF] [perma-orange]
(Assignee)

Updated

5 years ago
Attachment #622585 - Attachment description: (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comments 23+28, 30, 34] → (Cv2) browser_popupNotification.js: Port |Bug 617553 - Doorhanger for add-on installation failures inside the AOM has no parent with chrome hidden|, Port patch Gv1-FF [Checked in: See comments 23+28, 30, 34(*2)]
(Assignee)

Comment 37

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1338445001.1338449007.28783.gz&fulltext=1
OS X 10.6 comm-aurora debug test mochitest-other on 2012/05/30 23:16:41

seamonkey2.11a2: verified.
status-seamonkey2.11: fixed → verified
Whiteboard: [fixed in SM 2.10: Cv2, Dv1a, Ev1; SM 2.12: Av1, Bv1-FF, Fv1, Gv1-FF] [perma-orange] → [fixed in SM 2.10: Cv2, Dv1a, Ev1; SM 2.11: Hv1; SM 2.12: Av1, Bv1-FF, Fv1, Gv1-FF] [perma-orange]
You need to log in before you can comment on or make changes to this bug.