crash in nsXPConnect::CheckForDebugMode @ js::AllFramesIter::AllFramesIter

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

15 Branch
All
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox15- affected)

Details

(Whiteboard: [js:inv:p1], crash signature)

(Reporter)

Description

6 years ago
It first appeared in 15.0a1/20120506. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0a48e6561534&tochange=94ce5f33a9ea

Signature 	js::AllFramesIter::AllFramesIter(js::StackSpace&) More Reports Search
UUID	bb3350c7-a77e-49df-bb81-de9512120507
Date Processed	2012-05-07 05:20:35
Uptime	6989
Last Crash	3.0 weeks before submission
Install Age	1.9 hours since version was first installed.
Install Time	2012-05-07 03:23:50
Product	Firefox
Version	15.0a1
Build ID	20120506030520
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x1808
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x954f, AdapterSubsysID: 16131462, AdapterDriverVersion: 8.632.1.2000
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- 
EMCheckCompatibility	True	
Total Virtual Memory	4294836224
Available Virtual Memory	3800096768
System Memory Use Percentage	42
Available Page File	4749881344
Available Physical Memory	2430988288

Frame 	Module 	Signature 	Source
0 	mozjs.dll 	js::AllFramesIter::AllFramesIter 	js/src/vm/Stack.cpp:1364
1 	mozjs.dll 	JSCompartment::hasScriptsOnStack 	js/src/jscompartment.cpp:562
2 	mozjs.dll 	JSCompartment::setDebugModeFromC 	js/src/jscompartment.cpp:588
3 	mozjs.dll 	JS_SetDebugModeForCompartment 	js/src/jsdbgapi.cpp:169
4 	xul.dll 	nsXPConnect::CheckForDebugMode 	js/xpconnect/src/nsXPConnect.cpp:2416
5 	xul.dll 	nsXPConnect::Push 	js/xpconnect/src/nsXPConnect.cpp:2500
6 	xul.dll 	nsContentUtils::WrapNative 	content/base/src/nsContentUtils.cpp:5912
7 	xul.dll 	nsXBLProtoImplAnonymousMethod::Execute 	content/xbl/src/nsXBLProtoImplMethod.cpp:335
8 	xul.dll 	nsBindingManager::ExecuteDetachedHandlers 	content/xbl/src/nsBindingManager.cpp:1094
9 	xul.dll 	nsGlobalWindow::PostHandleEvent 	dom/base/nsGlobalWindow.cpp:2574
10 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:352
11 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:404
12 	xul.dll 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:684
13 	xul.dll 	NS_IsMainThread_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:138
14 	xul.dll 	nsDocShell::FirePageHideNotification 	docshell/base/nsDocShell.cpp:1620
15 	xul.dll 	nsTArray<nsCOMPtr<nsIDocShell>,nsTArrayDefaultAllocator>::AppendElements<nsQuery 	obj-firefox/dist/include/nsTArray.h:902
16 	xul.dll 	mozilla::Preferences::RemoveObserver 	modules/libpref/src/Preferences.cpp:1377
17 	xul.dll 	nsDocShell::Destroy 	docshell/base/nsDocShell.cpp:4667
18 	xul.dll 	nsWebShellWindow::Destroy 	xpfe/appshell/src/nsWebShellWindow.cpp:787
19 	gkmedias.dll 	_cairo_win32_surface_fallback_paint 	gfx/cairo/cairo/src/cairo-win32-surface.c:3374
20 	user32.dll 	wcscpy_s

More reports at:
https://crash-stats.mozilla.com/report/list?signature=js%3A%3AAllFramesIter%3A%3AAllFramesIter%28js%3A%3AStackSpace%26%29
https://crash-stats.mozilla.com/report/list?signature=js%3A%3AAllFramesIter%3A%3AAllFramesIter
(Reporter)

Updated

6 years ago
Duplicate of this bug: 752501
(Reporter)

Updated

6 years ago
Crash Signature: [@ js::AllFramesIter::AllFramesIter(js::StackSpace&)] [@ js::AllFramesIter::AllFramesIter] → [@ js::AllFramesIter::AllFramesIter(js::StackSpace&) ] [@ js::AllFramesIter::AllFramesIter ]
(Reporter)

Comment 2

6 years ago
It's #9 top crasher over the last 3 days.

Two comments say it occurs while closing Firefox.
tracking-firefox15: --- → ?
Keywords: topcrash
It is crashing with a null point error after JS_SetDebugModeForCompartment is called. Could be a regression from some of the Debugger patch work done recently.
Whiteboard: [js:p1:fx15][js:investigate][js:ni]
(In reply to nihsanullah from comment #3)
> It is crashing with a null point error after JS_SetDebugModeForCompartment
> is called. Could be a regression from some of the Debugger patch work done
> recently.

Jason, Scoobidiver's regression range has several debugger patches from you--could you take a look?
status-firefox15: --- → affected
tracking-firefox15: ? → +
Switching to new inv tag format.
Whiteboard: [js:p1:fx15][js:investigate][js:ni] → [js:inv:p1][js:ni]
(Reporter)

Comment 6

6 years ago
There are no crashes after 15.0a1/20120516040221.
(Reporter)

Updated

6 years ago
Keywords: topcrash
(Reporter)

Comment 7

5 years ago
I close it as WFM.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
tracking-firefox15: + → -
Whiteboard: [js:inv:p1][js:ni] → [js:inv:p1]
You need to log in before you can comment on or make changes to this bug.