Firefox cannot be ended after attempt to print

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: Matthias.R.Engelhardt, Unassigned)

Tracking

({reproducible})

12 Branch
x86_64
Windows 7
reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

I was using application Visma PX. I tried to print a time report which was in Ready state. In the print dialog, I changed paper format from "Portrait" to "Landscape".


Actual results:

Print seems to be acknowledged, and done; but I get no message "sent to printer", and neither a printed sheet of paper. And on that, I cannot terminate Firefox in the usual way; this can only be done from the Windows Task Manager (or by Shutdown, which I did not try).


Expected results:

Print should be sent to printer, printed there, and Firefox should continue normally, includint that I can end it the normal way (clicking the "x" in the rightmost upmost corner).
(Reporter)

Comment 1

7 years ago
I have a dump of the situation, but failed to attach it (probably because it is too big; 325 MB, compressed to 86 MB)
Keywords: reproducible

Comment 2

7 years ago
What is "Visma PX", and any chance you can provide a testcase? 
Also see http://support.mozilla.org/en-US/kb/Firefox%20prints%20incorrectly

Updated

6 years ago
Flags: needinfo?(Matthias.R.Engelhardt)
(Reporter)

Comment 3

6 years ago
Sorry; I did not get the information that you requested more information until now. Visma PX is a CRM, project management and invoicing system, used especially in northern Europe. I got the error when working at a Swedish company, but I am no longer employed there. Therefore, I cannot reproduce the problem any more, unfortunately.
A workaround was for me to use Chrome instead Firefox when I wanted to print in Visma PX.
Meanwhile, I think that some of the Visma JavaScript routines is depending on IE / Chrome interfaces which are not available in Firefox. Perhaps the routine throws some error, catches it and comes to a loop in this way; at the same time, it seems to block termination requests.
I propose to close the error, until a similar problem is reported again.
Flags: needinfo?(Matthias.R.Engelhardt)
Close -> by request in comment 3 until we get a test case
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.