Last Comment Bug 752461 - First time after choosing to "Never activate plugins for this site" the video is still playing
: First time after choosing to "Never activate plugins for this site" the video...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 14 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: David Keeler [:keeler] (use needinfo?)
:
Mentors:
Depends on:
Blocks: click-to-play
  Show dependency treegraph
 
Reported: 2012-05-07 05:20 PDT by Paul Silaghi, QA [:pauly]
Modified: 2012-05-11 04:46 PDT (History)
5 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch + test (4.09 KB, patch)
2012-05-08 13:54 PDT, David Keeler [:keeler] (use needinfo?)
jaws: review+
jaws: feedback+
Details | Diff | Review
patch v2 + test (4.12 KB, patch)
2012-05-08 14:44 PDT, David Keeler [:keeler] (use needinfo?)
dkeeler: review+
Details | Diff | Review

Description Paul Silaghi, QA [:pauly] 2012-05-07 05:20:01 PDT
STR:
1. Make sure plugins.click_to_play pref is set on TRUE in about:config
2. Open http://www.youtube.com/
3. Click on a video
4. Click on the plugin icon in the location bar
5. Choose to "Never activate plugins for this site"
6. Click on the video screen

Expected results:
The video should not play

Actual results:
The video starts playing
Comment 1 David Keeler [:keeler] (use needinfo?) 2012-05-07 10:25:43 PDT
To clarify, are you saying that if a user chooses "Never activate plugins...", when they then click on a plugin, it should not play? If so, I think this might confuse users ("I clicked on the plugin, but it's not playing?"). In fact, I think we should get rid of the "never activate plugins..." option altogether, because all we're really saying there is "never activate plugins automatically on this site", which is what happens if you have click-to-play enabled in the first place.
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-05-07 12:12:00 PDT
Fixing this bug is pretty simple, we should just iterate through the plugins array and hide the overlay.

As far as the ability to always deny, the benefit is that viewing pages doesn't show the overlay and the notification icon won't appear. I don't think we should remove this ability.
Comment 3 David Keeler [:keeler] (use needinfo?) 2012-05-08 13:54:46 PDT
Created attachment 622134 [details] [diff] [review]
patch + test
Comment 4 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-05-08 14:01:56 PDT
Comment on attachment 622134 [details] [diff] [review]
patch + test

Review of attachment 622134 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Thanks :)
Comment 5 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-05-08 14:07:12 PDT
Comment on attachment 622134 [details] [diff] [review]
patch + test

Review of attachment 622134 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the one change mentioned below.

::: browser/base/content/browser.js
@@ +7333,5 @@
>                              messageString, "plugins-notification-icon",
>                              mainAction, secondaryActions, options);
>    },
>  
> +  removeClickToPlayOverlays: function (aContentWindow) {

Please put an underscore in front of the function name here and name the anonymous function PH_removeClickToPlayOverlays.
Comment 6 David Keeler [:keeler] (use needinfo?) 2012-05-08 14:44:53 PDT
Created attachment 622152 [details] [diff] [review]
patch v2 + test

Updated patch per jaws' comments. Carrying over r+
Try run: https://tbpl.mozilla.org/?tree=Try&rev=9c46687a0659
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-05-09 16:05:14 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/23f45cac342f
Comment 8 Ed Morley [:emorley] 2012-05-10 08:02:17 PDT
https://hg.mozilla.org/mozilla-central/rev/23f45cac342f
Comment 9 Paul Silaghi, QA [:pauly] 2012-05-11 02:54:47 PDT
Black screen instantly appears when choosing to "Never activate plugins for this site".
Verified fixed on FF 15.0a1 (2012-05-10) on Win 7/64, Ubuntu 12.04 and Mac OS X 10.7.
Comment 10 Paul Silaghi, QA [:pauly] 2012-05-11 04:46:02 PDT
(In reply to Jared Wein [:jaws] from comment #2)
> As far as the ability to always deny, the benefit is that viewing pages
> doesn't show the overlay and the notification icon won't appear. I don't
> think we should remove this ability.

One disadvantage of this would be that if someone else will use the computer or event the owner after a long time might don't know why youtube.com apparently doesn't work.
In fact it's the same functionality, both with or without the CtP notification.

Note You need to log in before you can comment on or make changes to this bug.