Last Comment Bug 752493 - Current metro builds crash on suspend
: Current metro builds crash on suspend
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86_64 Windows 8.1
: -- critical (vote)
: mozilla16
Assigned To: Brian R. Bondy [:bbondy]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 07:24 PDT by Jim Mathies [:jimm]
Modified: 2014-07-24 11:06 PDT (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Callstack when there is a crash (3.93 KB, text/plain)
2012-05-11 12:18 PDT, Brian R. Bondy [:bbondy]
no flags Details
Call stack from within the suspend callback when there is no crash (5.01 KB, text/plain)
2012-05-11 12:19 PDT, Brian R. Bondy [:bbondy]
no flags Details

Description Jim Mathies [:jimm] 2012-05-07 07:24:17 PDT
This is still present. Was hoping some of the event work we did a week ago would fix this but it didn't.

STR:

1) launch metro fx
2) switch to another ap

fx crashes before receiving the suspend event.
Comment 1 Brian R. Bondy [:bbondy] 2012-05-08 12:39:52 PDT
I'm working on this, what a strange crash :(
Comment 2 Brian R. Bondy [:bbondy] 2012-05-11 12:18:43 PDT
Created attachment 623247 [details]
Callstack when there is a crash
Comment 3 Brian R. Bondy [:bbondy] 2012-05-11 12:19:18 PDT
Created attachment 623248 [details]
Call stack from within the suspend callback when there is no crash
Comment 4 Jim Mathies [:jimm] 2012-05-11 12:22:00 PDT
Benjamin, Brian's planning to write something up for the report. We'll plan on filing beginning of next week assuming we don't have a break through between now and then.

support entry page is here - 

http://support.microsoft.com/select/?target=assistance

There's no windows 8, so I just selected win7. They route us to the right place. 

for secondary options:

1) I use it as an IT Professional, developer or Microsoft partner
2) Internal windows based applications and components (drop down)
3) Base windows services

after that they need the msdn support account info.
Comment 5 Brian R. Bondy [:bbondy] 2012-05-11 12:25:13 PDT
We're working on a metro style enabled desktop browser which makes use of XAML interop via a SwapChainBackgroundPanel.
Since we started using XAML interop, we started getting crashes on suspend.
We think that it is related to a bug outside of our code.

The crash does not always happen, but it usually does.
You can reproduce by opening our app, switching to classic Desktop, and then waiting 10 seconds.

When the crashes happen our Suspending event callback is not hit.
Here is the callstack when it crashes:
https://bugzilla.mozilla.org/attachment.cgi?id=623247

When the crash does not happen, our Suspending event callback is hit.
Here is the callstack when it does not crash:
https://bugzilla.mozilla.org/attachment.cgi?id=623248

The relevant code can be found here:
http://hg.mozilla.org/projects/elm

And in particular see /widget/windows/winrt/MetroApp.cpp
Comment 7 Brian R. Bondy [:bbondy] 2012-05-11 13:25:08 PDT
Should also mention that this is what comes up in the debug/output window:

First-chance exception at 0x772C33A5 (ntdll.dll) in fennec.exe: 0xC0000005: Access violation reading location 0x00000000.
Unhandled exception at 0x772C33A5 (ntdll.dll) in fennec.exe: 0xC0000005: Access violation reading location 0x00000000.
Comment 8 Jim Mathies [:jimm] 2012-05-11 13:31:55 PDT
I'm working on a fresh test build with all the latest code changes and the xaml interop, should have an install up on the wiki by Monday.
Comment 9 Brian R. Bondy [:bbondy] 2012-05-14 11:51:43 PDT
To test this out you can see this build: 5-14 build
https://wiki.mozilla.org/Firefox/Windows_8_Integration#Metro_Test_Install
Comment 10 Brian R. Bondy [:bbondy] 2012-05-21 18:32:09 PDT
MS has reproduced this issue and expects a fix for the release preview.
Comment 11 Brian R. Bondy [:bbondy] 2012-06-06 13:46:04 PDT
MS said that they are no longer supporting XAML interop and I verified this is fixed after reverting XAML interop.

Note You need to log in before you can comment on or make changes to this bug.