Copy Image broken on Nightly

RESOLVED FIXED in seamonkey2.12

Status

SeaMonkey
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Phoenix, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
seamonkey2.12
regression

SeaMonkey Tracking Flags

(seamonkey2.10 fixed, seamonkey2.11 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Right click - Copy Image is partially broken on nightly, now instead of copying image address it copies image by itself. Firefox doesn't have problem, because have separate menu options Copy Image and Copy Image Location.
Last "good" nightly: 2012-05-02-00-30-23-comm-central-trunk
First "bad" nightly: 2012-05-03-00-30-35-comm-central-trunk
Regression from Bug 749527?

Updated

5 years ago
Blocks: 749527

Updated

5 years ago
Component: UI Design → General
QA Contact: ui-design → general
Hardware: x86_64 → Other
So probably the easiest way for you to get what you want is to either:
1) Add a second menu item like Firefox has
2) If you really do want all formats on the clipboard then add a new command for:
PRInt32 copyFlags = nsIContentViewerEdit::COPY_IMAGE_ALL;

Here is similar code to what you would need to do that (Except you'd use it for COPY_IMAGE_ALL):
https://bug749527.bugzilla.mozilla.org/attachment.cgi?id=619045
(Assignee)

Comment 2

5 years ago
Created attachment 622008 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #622008 - Flags: review?(philip.chee)

Comment 3

5 years ago
Comment on attachment 622008 [details] [diff] [review]
Proposed patch

This patch works for me. In WordPerfect Edit->Paste Special I get a choice of
Unformatted Text
Unicode
Device Independent Bitmap
Attachment #622008 - Flags: review?(philip.chee) → review+

Comment 4

5 years ago
Created attachment 622040 [details]
Screenshot of Clipboard Viewer

Screenshot showing all the formats available when copying an image.
(Assignee)

Comment 5

5 years ago
This code snippet works in windows with a <browser> element:

function CopyImage()
{
  var contentViewerEdit = getBrowser().contentViewerEdit;
  contentViewerEdit.copyImage(contentViewerEdit.COPY_IMAGE_ALL);
}

Unfortunately I don't know if we can rely on that.

Comment 6

5 years ago
> Unfortunately I don't know if we can rely on that.
Yeah lets go with your current patch. Please push stat!
(Assignee)

Comment 7

5 years ago
Pushed changeset e2a736a2a7b0 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

5 years ago
Comment on attachment 622008 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 749527
User impact if declined: Unable to copy image location
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String changes made by this patch: None
Attachment #622008 - Flags: approval-comm-beta?
Attachment #622008 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #622008 - Flags: approval-comm-beta?
Attachment #622008 - Flags: approval-comm-beta+
Attachment #622008 - Flags: approval-comm-aurora?
Attachment #622008 - Flags: approval-comm-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [transplant e2a736a2a7b0 to c-a, c-b]

Comment 9

5 years ago
Pushed to comm-aurora:
http://hg.mozilla.org/releases/comm-aurora/rev/888234d04ea9
Pushed to comm-beta:
http://hg.mozilla.org/releases/comm-beta/rev/3a7dc5e2cb05
Keywords: checkin-needed
OS: Windows 7 → All
Hardware: Other → All
Whiteboard: [transplant e2a736a2a7b0 to c-a, c-b]

Updated

5 years ago
status-seamonkey2.10: --- → fixed
status-seamonkey2.11: --- → fixed
tracking-seamonkey2.12: ? → ---
Target Milestone: --- → seamonkey2.12
You need to log in before you can comment on or make changes to this bug.