Last Comment Bug 752781 - Intermittent test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
: Intermittent test_bug607464.html | Pixel scrolling should have finished after...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-05-07 19:33 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2015-02-27 12:02 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix test (1.73 KB, patch)
2012-05-22 23:33 PDT, Robert O'Callahan (:roc) (email my personal email if necessary)
mats: review+
Details | Diff | Splinter Review

Description Ryan VanderMeulen [:RyanVM] 2012-05-07 19:33:53 PDT
This just started failing in the last day or two on both Windows and Linux so far.

https://tbpl.mozilla.org/php/getParsedLog.php?id=11532937&tree=Firefox
Rev3 Fedora 12x64 mozilla-central pgo test mochitests-1/5 on 2012-05-07 07:04:01 PDT for push 448f554f6acb

58629 INFO TEST-START | /tests/content/events/test/test_bug607464.html
58630 INFO TEST-INFO | /tests/content/events/test/test_bug607464.html | must wait for load
58631 INFO TEST-INFO | /tests/content/events/test/test_bug607464.html | must wait for focus
58632 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
58633 INFO TEST-END | /tests/content/events/test/test_bug607464.html | finished in 233ms
Comment 1 Phil Ringnalda (:philor) 2012-05-07 19:56:25 PDT
A more accurate time would probably be "started failing right around the time compartment-per-global landed, along with several other scrolling-related tests, but nobody wanted to get stuck filing it."
Comment 2 Treeherder Robot 2012-05-08 07:35:29 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11569409&tree=Firefox
Rev3 Fedora 12x64 mozilla-central pgo test mochitests-1/5 on 2012-05-08 06:56:22
slave: talos-r3-fed64-044

58653 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 3 Treeherder Robot 2012-05-09 22:58:07 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11632841&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound pgo test mochitests-1/5 on 2012-05-09 22:33:22
slave: talos-r3-fed64-038

58649 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 4 Treeherder Robot 2012-05-11 00:06:55 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11668760&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-1/5 on 2012-05-10 23:43:20
slave: talos-r3-xp-072

60239 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 5 Treeherder Robot 2012-05-11 03:41:48 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11671797&tree=Firefox
Rev3 WINNT 6.1 mozilla-central opt test mochitests-1/5 on 2012-05-11 03:18:08
slave: talos-r3-w7-015

60223 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 6 Treeherder Robot 2012-05-11 14:47:50 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11686241&tree=Fx-Team
Rev3 WINNT 5.1 fx-team opt test mochitests-1/5 on 2012-05-11 13:34:26
slave: talos-r3-xp-050

60194 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
88804 ERROR TEST-UNEXPECTED-FAIL | /tests/content/html/document/test/test_bug445004.html | an unexpected uncaught JS exception reported through window.onerror - TypeError: uri.match(/^http:\/\/([a-z.0-9]*)/) is null at http://mochi.test:8888/tests/content/html/document/test/test_bug445004.html:50
Comment 7 Treeherder Robot 2012-05-12 04:26:16 PDT
ttaubert
https://tbpl.mozilla.org/php/getParsedLog.php?id=11701724&tree=Firefox
Rev3 Fedora 12 mozilla-central pgo test mochitests-1/5 on 2012-05-12 04:03:55
slave: talos-r3-fed-032

58660 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 8 Treeherder Robot 2012-05-14 09:01:28 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11727738&tree=Fx-Team
Rev3 WINNT 6.1 fx-team opt test mochitests-1/5 on 2012-05-14 08:14:21
slave: talos-r3-w7-043

60247 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 9 Treeherder Robot 2012-05-15 05:08:36 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11754689&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitests-1/5 on 2012-05-15 00:47:00
slave: talos-r3-xp-065

60226 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 10 Treeherder Robot 2012-05-15 07:18:53 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11763157&tree=Firefox
Rev3 WINNT 5.1 mozilla-central pgo test mochitests-1/5 on 2012-05-15 06:48:39
slave: talos-r3-xp-073

60261 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 11 Treeherder Robot 2012-05-18 12:58:48 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=11871534&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-1/5 on 2012-05-18 12:29:54
slave: talos-r3-xp-052

60702 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 12 Treeherder Robot 2012-05-21 07:23:55 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11916441&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitests-1/5 on 2012-05-21 06:58:53
slave: talos-r3-xp-021

60674 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 13 Treeherder Robot 2012-05-21 12:20:21 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11922036&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound pgo test mochitests-1/5 on 2012-05-21 11:52:36
slave: talos-r3-xp-046

60656 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 14 Treeherder Robot 2012-05-22 21:27:30 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=11972884&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-1/5 on 2012-05-22 21:06:13
slave: talos-r3-xp-042

60694 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 15 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-22 23:27:46 PDT
I'm not sure how this test worked between April 30 and May 7; as far as I can tell, the test is failing due to changeset c70f3a9b31f8.

It initiates scrolling (asynchronous but not smooth) then does a setTimeout(0) to check the results and asserts that scrolling has actually happened. However, now that AsyncScroll isn't flushed until the refresh driver runs, the setTimeout could easily happen before the refresh driver runs the AsyncScroll.
Comment 16 Olli Pettay [:smaug] 2012-05-22 23:33:17 PDT
Could an animationframe callback initiate the setTimeout(0)?
Comment 17 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-22 23:33:50 PDT
Created attachment 626341 [details] [diff] [review]
fix test
Comment 18 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-22 23:34:17 PDT
(In reply to Olli Pettay [:smaug] from comment #16)
> Could an animationframe callback initiate the setTimeout(0)?

Yeah, that's more or less what I'm doing.
Comment 19 Mats Palmgren (:mats) 2012-05-22 23:44:54 PDT
Comment on attachment 626341 [details] [diff] [review]
fix test

Please update the "0-interval timer" part in the is() comment too.  r=mats
Comment 20 Treeherder Robot 2012-05-23 06:49:44 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11987827&tree=Firefox
Rev3 WINNT 5.1 mozilla-central pgo test mochitests-1/5 on 2012-05-23 06:10:49
slave: talos-r3-xp-004

60702 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 21 Treeherder Robot 2012-05-23 10:18:40 PDT
jwalden
https://tbpl.mozilla.org/php/getParsedLog.php?id=11975750&tree=Try
Rev3 WINNT 5.1 try opt test mochitests-1/5 on 2012-05-22 22:49:12
slave: talos-r3-xp-033

60694 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 22 Treeherder Robot 2012-05-23 21:22:13 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12010097&tree=Firefox
Rev3 WINNT 5.1 mozilla-central opt test mochitests-1/5 on 2012-05-23 19:38:38
slave: talos-r3-xp-039

60673 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after waiting for one 0-interval timer. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 23 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-05-24 03:40:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/347e2fe15b54
Comment 24 :Ms2ger (⌚ UTC+1/+2) 2012-05-25 08:25:39 PDT
https://hg.mozilla.org/mozilla-central/rev/347e2fe15b54
Comment 25 Treeherder Robot 2013-04-03 04:54:08 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=21381700&tree=Mozilla-B2g18
Rev5 MacOSX Mountain Lion 10.8 mozilla-b2g18 opt test mochitest-1 on 2013-04-02 21:30:57
slave: talos-mtnlion-r5-027

46016 ERROR TEST-UNEXPECTED-FAIL | /tests/content/events/test/test_bug607464.html | Pixel scrolling should have finished after one refresh driver iteration. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 26 Treeherder Robot 2015-02-06 05:47:33 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=fx-team&job_id=1915482
repository: fx-team
start_time: 2015-02-06T03:56:18
who: rvandermeulen[at]mozilla[dot]com
machine: talos-mtnlion-r5-058
buildname: Rev5 MacOSX Mountain Lion 10.8 fx-team opt test mochitest-2
revision: eecd602fe207

249 INFO TEST-UNEXPECTED-FAIL | dom/events/test/test_bug607464.html | Pixel scrolling should have finished after one refresh driver iteration. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15
Comment 27 Treeherder Robot 2015-02-27 12:02:18 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=b2g-inbound&job_id=1420453
repository: b2g-inbound
start_time: 2015-02-27T11:20:51
who: rvandermeulen[at]mozilla[dot]com
machine: t-snow-r4-0108
buildname: Rev4 MacOSX Snow Leopard 10.6 b2g-inbound debug test mochitest-2
revision: ee5d1f234412

249 INFO TEST-UNEXPECTED-FAIL | dom/events/test/test_bug607464.html | Pixel scrolling should have finished after one refresh driver iteration. We shouldn't be scrolling smoothly, even though the pref is set. - got 0, expected 15

Note You need to log in before you can comment on or make changes to this bug.