[FLOAT]Left float to the right of right edge of normal flow box doesn't cause wrap around [FLOAT]

RESOLVED FIXED in mozilla1.9.1b3

Status

()

Core
Layout: Floats
P3
normal
RESOLVED FIXED
17 years ago
8 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: dbaron)

Tracking

(Blocks: 1 bug, {css1, testcase})

Trunk
mozilla1.9.1b3
css1, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P3][CSS1-5.5.25] important floater bug, URL)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   Float a left float to the right of the right edge of a normal flow box, as
   in: http://hixie.ch/tests/adhoc/css/box/float/006.xml

ACTUAL RESULTS
   We don't mvoe the text down.

EXPECTED RESULTS
   See test case.

This is yet another floater bug. I feel almost embarassed to file these now. We
have so many it's not even funny. Oh, by the way, Opera gets this right (in 
HTML, anyway). Mac IE and Win IE get this wrong because they misplace the box
altogether, so I guess at least with this one we aren't doing altogether badly.

cc'ing dbaron (out of habbit) and glazman (he asked me to CC him on CSS bugs).
(Reporter)

Comment 1

17 years ago
Triaging: floater bug -> attinasi
Assignee: karnaze → attinasi
Keywords: css1, mozilla1.0, testcase
QA Contact: petersen → ian
Whiteboard: [Hixie-P3] important floater bug
(Reporter)

Updated

17 years ago
Blocks: 78094

Updated

16 years ago
Whiteboard: [Hixie-P3] important floater bug → [FLOAT][Hixie-P3] important floater bug
Target Milestone: --- → mozilla1.0.1
Moved FLOAT to Summary
Summary: Left float to the right of right edge of normal flow box doesn't cause wrap around [FLOAT] → [FLOAT]Left float to the right of right edge of normal flow box doesn't cause wrap around [FLOAT]
Whiteboard: [FLOAT][Hixie-P3] important floater bug → [Hixie-P3] important floater bug

Comment 3

16 years ago
Moving Mozilla 1.01 bugs to 'future' milestone with priority P1

I will be pulling bugs from 'future' milestones when scheduling later work.
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future
Whiteboard: [Hixie-P3] important floater bug → [Hixie-P3][CSS1-5.5.25] important floater bug

Comment 4

15 years ago
==> Floats
Assignee: attinasi → float
Component: Layout → Layout: Floats
(Assignee)

Updated

15 years ago
Depends on: 191448

Comment 5

10 years ago
WORKSFORME?
It doesn't match how Safari or Opera renders it, so which of the three renderings is correct?

Comment 7

10 years ago
Err, wait, I misread the testcase; our rendering is probably wrong.  (The only reason we can pull off a rendering like this is due to our over-engineered space manager which is way too flexible.)

I can't seem to find any text in the spec that actually says that text isn't allowed to flow to the left of a left float, though.

Comment 8

10 years ago
(Safari and Opera render the testcase slightly differently from each other due to font-size differences; the significant bit is the text in the second block.)
Assignee: layout.floats → nobody
QA Contact: ian → layout.floats

Comment 9

8 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 and 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8pre) Gecko/20100129 Shiretoko/3.5.8pre

The given testcase from the url matches with: Firefox 3.5.8, Firefox 3.6, Opera 10.1, Chrome 4, Safari 4.

-> WFM
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

8 years ago
This was fixed by bug 191448; I confirmed by checking the 1.9.1-branch nightlies for 2009-02-12 and 2009-02-13:  it was fixed between those nightlies.  (I used branch because I wanted to check that it wasn't fixed by the patch, broken by the followups, and then refixed later.)
Assignee: nobody → dbaron
Priority: P1 → P3
Resolution: WORKSFORME → FIXED
Target Milestone: Future → mozilla1.9.1b3
You need to log in before you can comment on or make changes to this bug.