Problems with layout

VERIFIED FIXED in M12

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
19 years ago
15 years ago

People

(Reporter: aanselmo, Assigned: Hixie (not reading bugmail))

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [NOTESTCASENEEDED], URL)

(Reporter)

Description

19 years ago
While I admit the new layout for the browser is quite nice, there are some
consistancy problems with producing webpages. For example take a gander at our
company website with the old Netscape or MSIE. (http://www.ceramicbulletin.org)
You'll see the side bars match up perfectly. Taken into the new Preview version
of Mozilla (M6) you'll see that there are now spaces between the images and our
webpages just doesn't work right.

This as well as other design inconsistencies should be taken into concern.
Perhaphs a throughal examination of websites with the current browser and the
preview browser side by side would reveal several descriptincies.

See also

http://anthony.anselmo.com
http://www.ceramicsmonthly.org
http://www.potterymaking.org
http://www.ac

Updated

19 years ago
Assignee: don → rickg
Component: Apprunner → Layout
QA Contact: leger → petersen

Comment 1

19 years ago
Assigning to Layout component.  petersen, can you check latest build for Mac
only (is so, mark [PP] in Summary) or same problem across all platforms.

Updated

19 years ago
Assignee: rickg → kipp
(Assignee)

Updated

19 years ago
Whiteboard: (py8ieh:will examine)
(Assignee)

Comment 2

19 years ago
The spacing problem listed is not a bug. Your pages are incorrectly rendered
by Nav4 and MSIE.

To get the rendering you are looking for, you should include the follownig in
your CSS:

   IMG { vertical-align: bottom; }

I will further examine these pages in the next few days.
(Assignee)

Updated

19 years ago
Whiteboard: (py8ieh:will examine)
(Assignee)

Comment 3

19 years ago
I am assigning this bug to myself, and will look at the pages in the near
future. If there are any problems, then I will file new bugs.

aanselmo@acers.org: Do you maintain the websites mentioned above?
(Assignee)

Updated

19 years ago
Assignee: kipp → py8ieh=bugzilla
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 4

19 years ago
Yes I do maintain the websites above. I use Adobe Golive for Macintosh.
(Reporter)

Comment 5

19 years ago
The pages where created with Adobe Golive 4.0. And considering that the pages
look fine in Nav4 and MSIE I think you guys need to adjust your new Nav browser
to work correctly with the current standard. Or at least inform Adobe to update
their product before you release your new browser. I don't have time to go back
through 100 pages and adjust the code that works in a browser that isn't going to
follow everyone else.

Plus there are a ton of webpages this effects, not just the ones from our
company. I don't see the logic in making a browser that doesn't comply to what is
already out there.

BTW this browser takes forever to get started on my machine, and I'm running a
G3.

http://www.cscarts.org

I also noticed you have this gap problem  when viewing other sites such as
Apple.com, Microsoft.com etc...
Sounds like a candidate for quirks mode.
(Reporter)

Comment 7

19 years ago
What is quirks mode?
Mozilla will have a mode such that if your page is not specified as HTML 4, it
support old 'quirks'.  HTML 4 pages will be rendered according to spec.  At
least, that's my understanding of it.
(Reporter)

Comment 9

19 years ago
So when will this feature be implemented?
No idea myself.  Ian, is this a valid quirk to pass on to some of the Netscape
layout guys?
(Reporter)

Comment 11

19 years ago
Basically put guys, you need to have the new netscape be compatible with the
previous one if you want it go anywhere, or even be able to content with IE.
I wouldn't start worrying too much yet - I don't think it would be released like
this, especially if its as prevalent as you say.  The idea of quirks mode is to
handle any bugs in old versions while making a clean break for HTML 4 pages,
which are rendered according to spec.

It's quite possible there's a duplicate bug of this somewhere too, in
particular, 5755 looks similar, and there's a few other bugs that look suss - do
a lookup on "spac" in the summary.

Ian, as far as I can see these pages have no CSS.  Now, I don't claim to be an
expert or anything near it, but my understanding of CSS was that you had a
browser stylesheet with a lower priority than the user and author stylesheet.
Therefore wouldn't it be up to the browser how to do this in the absence of an
author or user stylesheet?  Is there a standard browser stylesheet the CSS spec
dictates in case of no attached stylesheet?  Or always?  Was this specified in
HTML before the presentational stuff was deprecated?  Just curious as to how
this is a "bug" in the previous versions.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Using nightly build 1999-09-01-09-M10 on Windows NT.
I can't see any problems at http://www.ceramicbulletin.org (the content must
have changed since this bug was reported since there is no sidebar there.)
The following 3 pages suffers from bug 5821:
http://anthony.anselmo.com
http://www.ceramicsmonthly.org
http://www.potterymaking.org
I can't see any problems with http://www.ac
Thus marking this bug as a dup of bug 5821.


*** This bug has been marked as a duplicate of 5821 ***
(Assignee)

Updated

18 years ago
Status: RESOLVED → REOPENED
Whiteboard: [NOTESTCASENEEDED]
Target Milestone: M12
(Assignee)

Comment 14

18 years ago
mats@symsoft.se: Thanks for you help, but I must reopen this bug. :-)

This is a metabug used for me to find all errors on the
   http://www.ceramicbulletin.org/
...website and others mentioned above. I have it only as a reminder that I must
do this. I am waiting for the layout engine to stabalise before carefully
examining the many pages on those sites for rendering inconsistencies.

aanselmo@acers.org: When I do start examining these websites carefully, I may
contact you about issues where Mozilla does the correct thing (as given by the
relevant specifications), but where this is not the behaviour you were seeking.
As noted above, we are implementing a NavQuirks mode which is designed to
emulate the old buggy behaviour, so there should be no problems.

matty@box.net.au: Quirks mode is actually already implemented, there is a switch
in one of the menus somewhere. Eventually we will decide on the quirks mode
based on the document's DOCTYPE declaration (see bug 1312). Also: yes, CSS has
a concept of a ua.css file (in Mozilla we call it that, look for it under the
resources directory). Look in the spec, it explains that any page has at least
three CSS stylesheets that affect it: the UA's stylesheet, the user's
stylesheet, and the document's stylesheet.


I'm marking this bug M12 (beta), I may push it over to M13 depending on time
constraints.
(Assignee)

Updated

18 years ago
Resolution: DUPLICATE → ---
Well that explains that my knowledge was right, but doesn't explain why the
current behaviour is "right".  Is the current behaviour right and the old
behaviour wrong, or are both equally right?
(Assignee)

Comment 16

18 years ago
Err... which behaviour, exactly?

Comment 17

18 years ago
There is a white vertical stripe down the middle of this page (on my linux
box)...Some sort of table issue.
The spaces between the images.
(Assignee)

Comment 19

18 years ago
matty: Yes, our current behaviour is correct per CSS2. This will be a NavQuirks
behaviour thing (being implemented Right Now...).
OK, what I really mean is, is solving this as easy as changing the browser
stylesheet for quirks mode?  If so, how is any one way of displaying it "right"?
(Assignee)

Comment 21

18 years ago
matty: It's done. See bug 5821.
Cool.  Are you seeing any improvement with recent builds Anthony?

So therefore would I be right in saying that both Moz's new and old behaviour
was right, according to spec, since it can have any browser stylesheet it wanted
to?
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 23

18 years ago
No, Moz's new behaviour (quirk mode only) is _wrong_. There is no way to
specify the behaviour that we currently have according to the CSS2 spec.
The behaviour is there as a compatability mode quirk only.
(Reporter)

Comment 24

18 years ago
Guys, you need to start talking english here, you are going way over my head. Let

me give you a little background about myself. I am a web designer, with moderate

html knowledge, but mainly work in Golive to build the sites I work on. My major

concern is that when you release the new Netscape Navigator that all my websites

show up consistantly with the previous browsers. Currently with the beta version

of mozilla there is a gap in my tables that I use for menus. The mozilla program

itself has gotten a bit more stable in recent builds, but I still feels needs a

lot of work.



Now when you guys are talking, I am trying to sort through all my email and

figure out what's going on. From what I take I am assuming that in the new

netscape there will be a feature for the new version of html as well as a way to

detect if the page is using the older style html. When the page is loaded the

browser will detemine which is which and display the page correctly? Am I correct

in this assumption?
(Assignee)

Comment 25

18 years ago
Yes, you are correct.

A minor correction, though: Mozilla is currently _pre_ beta. We have not yet
released a beta build. Of course there are problems in the current releases:
we are still writing it! If there were no bugs, we would not have to work on it.
(Assignee)

Updated

18 years ago
Depends on: 6540, 7398, 8559, 10276
(Assignee)

Comment 26

18 years ago
Since I am now back behind a proxy, I cannot investigate these sites with
Mozilla until the proxy support is complete. Making dependencies.
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 27

18 years ago
With Mozilla Build 10, this problem is gone. Thank you.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 28

18 years ago
With the Dec 01 Mac build, this page renders correctly. Marking verified fixed.

Updated

15 years ago
No longer depends on: 7398
You need to log in before you can comment on or make changes to this bug.