The default bug view has changed. See this FAQ.

Typo in calculation of 'allowExpansion' (result will always be an empty rect) in nsDisplayScrollLayer::ComputeVisibility

RESOLVED FIXED in mozilla15

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

unspecified
mozilla15
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
http://hg.mozilla.org/mozilla-central/annotate/e4f9e2eab6b1/layout/base/nsDisplayList.cpp#l2111
(Assignee)

Comment 1

5 years ago
Created attachment 622017 [details] [diff] [review]
part 1, fix typo

Looking at the 'allowExpansion' calculations in nsDisplayOpacity/nsDisplayClip
I guess this is what was intended.
Attachment #622017 - Flags: review?(roc)
(Assignee)

Comment 2

5 years ago
Created attachment 622019 [details] [diff] [review]
part 2, simplify IntersectRect calculations

I guess the compiler can optimize away the unnecessary initialization and
IsEmpty() calculation, it's just simpler to not do it.
Attachment #622019 - Flags: review?(roc)
(Assignee)

Comment 3

5 years ago
https://tbpl.mozilla.org/?usebuildbot=1&tree=Try&rev=ef827e2cdd2d
Attachment #622017 - Flags: review?(roc) → review+
Attachment #622019 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/de3ba7db062a
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c40b33bfda5
Target Milestone: --- → mozilla15
https://hg.mozilla.org/mozilla-central/rev/de3ba7db062a
https://hg.mozilla.org/mozilla-central/rev/0c40b33bfda5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.