Closed Bug 753049 Opened 8 years ago Closed 7 years ago

pages loaded in the background losing interactivity not re-rendering when zooming

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 748509

People

(Reporter: heycam, Unassigned)

Details

Often a page I load in the background (so by long tapping a link and choosing to open in a new tab) will be not completely functional when I eventually switch to it.

The page will look OK when switching to it initially, but any kind of interaction on the page (attempting to tap on links and buttons etc.) doesn't result in any action.  If I zoom in the page, then it renders just a scaled up version of the bitmap that the initial view of the page was.  If I pan some amount outside of the initial view of the page, I will come across even lower resolution tiles of rendering of the page. All of this can only be overcome by reloading the page.

My mode of usage on the phone, say with reading the front page of Reddit or Hacker News, is to open a bunch of tabs in the background and then to switch to them to read.  I haven't seen this problem occur when loading a page in the foreground, but this recently has been happening about 50% of the time when I load a page in the background.  (I've just restarted the app and am currently unable to reproduce, but I will report back with better STR when I can.)
Version: unspecified → Trunk
Dupe of bug 752368 perhaps?
Sounds a little similar, but not exactly.  I tried Vlad's tryserver build from that bug but it did not help with this one.
Going in to the awesome screen and back out again seems to get things rendering again when I get into this state.
This actually might be bug 748509.
Bug 748509 has been fixed, do you still see this problem?
I do not see the problem any more, thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748509
You need to log in before you can comment on or make changes to this bug.