Last Comment Bug 753142 - NS_ERROR_XPC_BAD_IID [nsIJSCID.createInstance] in B2G builds
: NS_ERROR_XPC_BAD_IID [nsIJSCID.createInstance] in B2G builds
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Jonathan Griffin (:jgriffin)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-08 15:14 PDT by Jonathan Griffin (:jgriffin)
Modified: 2012-05-09 13:18 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (463 bytes, patch)
2012-05-08 16:44 PDT, Jonathan Griffin (:jgriffin)
philipp: review+
Details | Diff | Review

Description Jonathan Griffin (:jgriffin) 2012-05-08 15:14:04 PDT
Since bug 749316 landed, the remote debugger (and thus Marionette) has been broken in B2G.  On startup, this error is shown:

I/Gecko   (   41): Error loading: chrome://global/content/devtools/dbg-server.js: [Exception... "Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.createInstance]"  nsresult: "0x80570018 (NS_ERROR_XPC_BAD_IID)"  location: "JS frame :: resource://gre/modules/jsdebugger.jsm :: <TOP_LEVEL> :: line 54"  data: no] - undefined

This error is pointing to:

http://mxr.mozilla.org/mozilla-central/source/js/ductwork/debugger/jsdebugger.jsm#54

This prevents us from running any tests in B2G, since they all rely on the remote debugger and Marionette.
Comment 1 Jonathan Griffin (:jgriffin) 2012-05-08 16:44:23 PDT
Created attachment 622207 [details] [diff] [review]
patch
Comment 2 Jonathan Griffin (:jgriffin) 2012-05-08 17:09:29 PDT
http://hg.mozilla.org/mozilla-central/rev/5593fb266719

Note You need to log in before you can comment on or make changes to this bug.