Last Comment Bug 753159 - Empty struct doesn't compile
: Empty struct doesn't compile
Status: RESOLVED FIXED
[b2g:blocking+][soft]
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla15
Assigned To: Chris Jones [:cjones] inactive; ni?/f?/r? if you need me
:
Mentors:
Depends on:
Blocks: 666693
  Show dependency treegraph
 
Reported: 2012-05-08 15:41 PDT by Chris Jones [:cjones] inactive; ni?/f?/r? if you need me
Modified: 2012-05-31 05:57 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Allow empty structs (2.39 KB, patch)
2012-05-24 16:50 PDT, Chris Jones [:cjones] inactive; ni?/f?/r? if you need me
bent.mozilla: review+
Details | Diff | Splinter Review
Test for bug 753159 (971 bytes, patch)
2012-05-24 16:50 PDT, Chris Jones [:cjones] inactive; ni?/f?/r? if you need me
no flags Details | Diff | Splinter Review

Description Chris Jones [:cjones] inactive; ni?/f?/r? if you need me 2012-05-08 15:41:52 PDT
|struct Foo {};| doesn't compile.  It's supposed to.
Comment 1 Chris Jones [:cjones] inactive; ni?/f?/r? if you need me 2012-05-24 16:50:14 PDT
Created attachment 627026 [details] [diff] [review]
Allow empty structs
Comment 2 Chris Jones [:cjones] inactive; ni?/f?/r? if you need me 2012-05-24 16:50:35 PDT
Created attachment 627027 [details] [diff] [review]
Test for bug 753159

Note You need to log in before you can comment on or make changes to this bug.