Swap remaining comm-* branches to Firefox infra

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: standard8, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [thunderbird][scl3])

Attachments

(1 attachment)

Deps
* New AUS server end-points up and running (bug 750644)
* Release automation at least semi-working (bug 750561)

What to do:
* swap aus.update.url to aus3.m.o
* turn off all of the old MoMo buildbot
* remove all the "-test" additions and correct tinderbox_trees on Firefox infra configurations for Thunderbird.

I'm hoping the latest we do this will be Friday, but we'll have to see how we're doing on the automation front.
(Assignee)

Updated

6 years ago
Assignee: nobody → coop
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [thunderbird][scl3]
(Assignee)

Comment 1

6 years ago
Created attachment 622731 [details] [diff] [review]
Move all comm-* branches onto Firefox infra

Also removes the special cases we had in place for try, central, and aurora.
Attachment #622731 - Flags: review?(mbanner)
Comment on attachment 622731 [details] [diff] [review]
Move all comm-* branches onto Firefox infra

Review of attachment 622731 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine, no -test left over afaict.
Attachment #622731 - Flags: review?(mbanner) → review+
(Assignee)

Comment 3

6 years ago
Am I clear to land this change now, or am I to wait on the dependent bugs?
I am happy with the risk if we land this change now. Please make sure jhopkins takes down the MoMo buildbot first.
(Assignee)

Comment 5

6 years ago
Comment on attachment 622731 [details] [diff] [review]
Move all comm-* branches onto Firefox infra

https://hg.mozilla.org/build/buildbot-configs/rev/bf75a376acee
Attachment #622731 - Flags: checked-in+
I've just scheduled a graceful shutdown of the MoMo production buildbot master.
(Assignee)

Comment 7

6 years ago
I should note that I haven't reconfig-ed the Firefox masters for this yet. If buildduty doesn't get a chance today, I will.
Buildbot masters were reconfigured this morning.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.