Closed Bug 753371 Opened 9 years ago Closed 9 years ago

Invalidation/painting issues when paging down PDF

Categories

(Firefox :: PDF Viewer, defect)

x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: bzbarsky, Unassigned)

References

()

Details

Steps to reproduce:

1)  Load http://cache.dealbreaker.com/uploads/2011/10/Greenlight-Capital-VIC-2011-Presentation-GMCR.pdf

2)  Page down using right arrow key to page 6

EXPECTED RESULTS: Rendered correctly

ACTUAL RESULTS: White blotches to the left and right of the slide heading and right below it (on top of the horizontal green line).  Scrolling up a bit with the arrow key or just invalidating the whole window (e.g. by switching focus out of it) repaints correctly.

This happens with various other parts of the slide deck too; it's particularly noticeable on page 28, where the graph's legend is completely obliterated by the white blotch.
I can't reproduce in current nightly.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified on the latest Nghtly and Aurora builds and the issue is no longer reproducible. 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/18.0 Firefox/18.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20.0 Firefox/20.0

Marking Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.