Last Comment Bug 753479 - Make HashTable's rekeyFront take a separate Lookup
: Make HashTable's rekeyFront take a separate Lookup
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Terrence Cole [:terrence]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 730933
  Show dependency treegraph
 
Reported: 2012-05-09 12:27 PDT by Terrence Cole [:terrence]
Modified: 2012-05-10 07:42 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (1.50 KB, patch)
2012-05-09 12:27 PDT, Terrence Cole [:terrence]
luke: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2012-05-09 12:27:07 PDT
Created attachment 622460 [details] [diff] [review]
v0

I was hoping to do without this for GenerationalGC, but I may have been a bit optimistic.  There are two things pushing me towards doing this now, rather than later.  1) I'm touching all of the call sites that would need this right now to update to an indirect IsAboutToBeFinalized.  There's little point dumping this onto whoever ends up doing MovingGC, since I've already done most of the work.   2) I think we may need this for proto objects in the initial shape table, even for GenerationalGC.
Comment 1 Luke Wagner [:luke] 2012-05-09 12:35:07 PDT
Comment on attachment 622460 [details] [diff] [review]
v0

I just noticed: could you replace 'table.match' with either 'match' or (if template errors...) HashTable::match?
Comment 2 Terrence Cole [:terrence] 2012-05-09 13:43:56 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/157bf3e3ccde
Comment 3 Ed Morley [:emorley] 2012-05-10 07:42:09 PDT
https://hg.mozilla.org/mozilla-central/rev/157bf3e3ccde

Note You need to log in before you can comment on or make changes to this bug.