Last Comment Bug 753607 - Overhaul existing Marionette WebAPI tests
: Overhaul existing Marionette WebAPI tests
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla15
Assigned To: Philipp von Weitershausen [:philikon]
:
Mentors:
Depends on: 753606
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 17:04 PDT by Philipp von Weitershausen [:philikon]
Modified: 2012-05-11 13:12 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (24.49 KB, patch)
2012-05-10 11:11 PDT, Philipp von Weitershausen [:philikon]
no flags Details | Diff | Review
v2 (24.59 KB, patch)
2012-05-10 14:24 PDT, Philipp von Weitershausen [:philikon]
jgriffin: review+
jgriffin: feedback+
Details | Diff | Review

Description Philipp von Weitershausen [:philikon] 2012-05-09 17:04:19 PDT
We can now use new_sandbox = False to make the JS global handling a bit easier.
Comment 1 Philipp von Weitershausen [:philikon] 2012-05-10 11:11:14 PDT
Created attachment 622799 [details] [diff] [review]
v1

Also added the SMS test (which currently fails, so it's added as a known fail). Also got some weird failures in the battery tests and test_log.py. I suspect something isn't cleaning up properly...
Comment 2 Philipp von Weitershausen [:philikon] 2012-05-10 14:24:20 PDT
Created attachment 622920 [details] [diff] [review]
v2

Rebased on top of bug 753606 v3
Comment 3 Jonathan Griffin (:jgriffin) 2012-05-10 15:34:44 PDT
Comment on attachment 622920 [details] [diff] [review]
v2

lgtm; I'll file a followup bug to address the exception race condition that was causing test_battery.html to fail
Comment 4 Philipp von Weitershausen [:philikon] 2012-05-11 09:48:06 PDT
Comment on attachment 622920 [details] [diff] [review]
v2

Turns out, the test failure is due to a bug in Marionette which jgriffin already fixed, so I'm now submitting this for review.
Comment 5 Jonathan Griffin (:jgriffin) 2012-05-11 10:32:06 PDT
Comment on attachment 622920 [details] [diff] [review]
v2

Review of attachment 622920 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Along with some of the other recent patches, here are the full test results:

SUMMARY
-------
passed: 55
failed: 0
todo: 0

We're obviously not calculating todo correctly, since we have two expected failures in this test set. I'll file a followup bug.
Comment 6 Philipp von Weitershausen [:philikon] 2012-05-11 13:12:53 PDT
https://hg.mozilla.org/mozilla-central/rev/7b5d636382b2

Note You need to log in before you can comment on or make changes to this bug.