Last Comment Bug 753615 - Ensure we don't re-enter a GC phase
: Ensure we don't re-enter a GC phase
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: [PTO to Dec5] Bill McCloskey (:billm)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 18:05 PDT by [PTO to Dec5] Bill McCloskey (:billm)
Modified: 2012-05-10 18:35 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.80 KB, patch)
2012-05-09 18:05 PDT, [PTO to Dec5] Bill McCloskey (:billm)
terrence.d.cole: review+
Details | Diff | Splinter Review

Description [PTO to Dec5] Bill McCloskey (:billm) 2012-05-09 18:05:37 PDT
Created attachment 622598 [details] [diff] [review]
patch

I noticed that the times from the error console were screwy in some cases. The problem is that we tell the statistics code that we're entering the mark phase, and then tell it again a little later. The code isn't designed to handle re-entry.

This patch asserts that we never re-enter a phase. It also fixes the case I found, where IncrementalMarkSlice enters the mark phase, and then re-enters it in EndMarkPhase.
Comment 1 Terrence Cole [:terrence] 2012-05-09 18:36:03 PDT
Comment on attachment 622598 [details] [diff] [review]
patch

Review of attachment 622598 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch.
Comment 2 [PTO to Dec5] Bill McCloskey (:billm) 2012-05-10 10:32:54 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a8b9ad3204ab
Comment 3 Joe Drew (not getting mail) 2012-05-10 18:35:46 PDT
https://hg.mozilla.org/mozilla-central/rev/a8b9ad3204ab

Note You need to log in before you can comment on or make changes to this bug.