Last Comment Bug 753619 - Fix the progress bar totals in jstest.py
: Fix the progress bar totals in jstest.py
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Terrence Cole [:terrence]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 18:40 PDT by Terrence Cole [:terrence]
Modified: 2012-05-11 11:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0 (13.37 KB, patch)
2012-05-10 16:09 PDT, Terrence Cole [:terrence]
dmandelin: review+
Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2012-05-09 18:40:44 PDT
Something in the previous refactorings has messed up the display of the progress bar such that it occasionally jumps over 100% and 80chars.
Comment 1 Terrence Cole [:terrence] 2012-05-10 16:09:45 PDT
Created attachment 622955 [details] [diff] [review]
v0

I wasn't able to figure out why we don't just always import and create the progress bar: there doesn't seem to be anything in there that is platform dependent or particularly resource intensive.

I've also simplified how we pass state around, since we're carrying options everywhere anyway, and cleaned up a few other odds and ends.
Comment 2 Terrence Cole [:terrence] 2012-05-10 18:09:32 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ec49b73ea28
Comment 3 Matt Brubeck (:mbrubeck) 2012-05-11 11:41:47 PDT
https://hg.mozilla.org/mozilla-central/rev/0ec49b73ea28

Note You need to log in before you can comment on or make changes to this bug.