Closed Bug 753708 Opened 11 years ago Closed 8 years ago

Tooltip hints on Mac are badly visible under a resized mouse pointer

Categories

(Firefox :: Untriaged, defect)

13 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 557754

People

(Reporter: axel.bock.mail, Unassigned)

Details

Attachments

(1 file)

Attached image FirefoxBug.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120501201020

Steps to reproduce:

I resized my mouse pointer on my MacBook in the system preferences to be more visible and hovered the mouse over an element which opens a tooltip.


Actual results:

Every time a tooltip shows it is partially hidden from the bigger-than-normal pointer, sometimes making the whole thing unreadable. (See attached screenshot from http://www.online-motor-deutschland.de/etown)


Expected results:

The tooltip should be displaced in a way it stays readable.
Hello Axel,

I just found this old report from 2012, that was never answered...
I have no Mac to reproduce, so I want to ask you if this report is still valid with an actual Version of Firefox?

thanks for your help, to finaly solve/close this.
Flags: needinfo?(justsomeoneoutthere)
yup, still valid. checked on the headlines on http://www.heise.de with FF 32 beta and large mouse pointer.

thbanks for getting back!

user agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Flags: needinfo?(justsomeoneoutthere)
I don't see how we should expect the tooltip position to adjust based on mouse cursor size.
Is that standard behavior in other browsers?
Neither Safari nor Chrome on Mac have the requested behavior; tooltips display the same regardless of cursor size. I'm pretty sure other OS platforms don't do it either. This bug should be changed to an Enhancement request, or closed as Invalid/Wontfix.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557754
You need to log in before you can comment on or make changes to this bug.